Language:
switch to room list switch to menu My folders
Go to page: First ... 117 118 119 120 [121] 122 123 124 125
[#] Mon Aug 28 2017 03:25:25 EDT from Maria @ Uncensored

Subject: Re: Sending Mail is not working

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Aug 27 2017 15:44:12 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Sending Mail is not working
550 (Requested action not taken: mailbox unavailable or relaying
denied)

the receiver Mail is valid and I used several others...

This message is generated when the receiving system rejected your email.
Citadel is contacting the remote server, but the remote server is rejecting what you're sending to it. This could be caused by a couple of different things:
1. Is your domain name set properly? If the remote system thinks it's receiving mail from a rogue domain it might get rejected.
2. Are you on a commercial ISP or a consumer ISP? While commercial ISP's generally give you a clear shot out to the Internet, consumer grade services often mess with connections to port 25; they'll either filter, redirect, or reject them outright.

As a test, you can try setting a known working third party email account as a smart host.

Hi IGnatius,

Indeed... It wasn`t Citadels fault... ;)))

All generic Servernames of my ISP (Strato) are rejected by other Mailservers... ;O

The solution is to set your own TLD and everything works fine.. ;)

 

ThX for your Help and best Wishes for your Health and a quick recovery... ;)

 

Bye,

Maria :)



[#] Mon Aug 28 2017 12:17:24 EDT from Maria @ Uncensored

Subject: Mail Aliases not beeing saved

[Reply] [ReplyQuoted] [Headers] [Print]

(newest Version over Easy Install)

 

Hi, another small Problem:

When I enter an E-Mail Alias into the Vcard of the user and hit save... it`s not been saved!

Not sure why... everything else, for example Fax, Telephone, Name is saved...

I found the file "mail.aliases" and made the changes there... but not shure about the syntax there, how to make one Mail Alias for 4 Users (so 3 Users share the same alias)

Checked also the permissions of the file "mail.aliases", seems to be OK (staff > 644)

ThX for any Help :)

Maria



[#] Mon Aug 28 2017 13:28:45 EDT from bravegnu @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Part 1: (text/x-markdown) (1388 bytes)

(text/x-markdown, 1484 bytes) [ View | Download ]
[#] Mon Aug 28 2017 13:31:38 EDT from bravegnu @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Empty message



[#] Mon Aug 28 2017 13:29:45 EDT from bravegnu @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Part 1: (text/x-markdown) (1387 bytes)

(text/x-markdown, 1481 bytes) [ View | Download ]
[#] Mon Aug 28 2017 14:15:30 EDT from bennabiy @ Uncensored

Subject: Markdown viewer disabled?

[Reply] [ReplyQuoted] [Headers] [Print]

Users who post in markdown just show up as a view/download...



[#] Mon Aug 28 2017 15:48:42 EDT from bravegnu @ Uncensored

Subject: Citadel + LDAP Issue

[Reply] [ReplyQuoted] [Headers] [Print]

Re-posting since the earlier post in markdown did not render correctly.

I am trying to setup a mail server using Citadel (v9.01) + LDAP + Squirrelmail. Everything seems to work, except for receiving mails. The FQDN is configured to be say example.com and I send an email to vijaykumar@example.com, from my login (vijaykumar) using squirrelmail. The email recipient address gets converted to "vijaykumar @ example.com", after a lookup in the Global Address Book, by Citadel, and eventually returns with the error message "Invalid recepient: vijaykumar @ example.com". So while I am able to send mails to other servers, I am not able receive mails or send mails within the server.

I suspect, there is a bug in the following code, in function alias() in internet_addressing.c:

    /* Change "user @ xxx" to "user" if xxx is an alias for this host */
    for (a=0; name[a] != '\0'; ++a) {
        if (name[a] == '@') {
            if (CtdlHostAlias(&name[a+1]) == hostalias_localhost) {
                name[a] = 0;
                MSG_syslog(LOG_INFO, "Changed to <%s>\n", name);
                break;
            }
        }
    }

This is supposed to convert "user @ xxx" to "user", as the comment suggests. The code locates '@' and passes the string after @ to CtdlHostAlias() using CtdlHostAlias(&name[a+1]). But if there is a space after the '@', then this should be CtdlHostAlias(&name[a+2]). Please do let me know if this is really a bug, in the code.



[#] Tue Aug 29 2017 06:51:50 EDT from bravegnu @ Uncensored

Subject: Re: Citadel + LDAP Issue

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Aug 28 2017 03:48:42 PM EDTfrom bravegnu @ Uncensored Subject: Citadel + LDAP Issue

Re-posting since the earlier post in markdown did not render correctly.

I am trying to setup a mail server using Citadel (v9.01) + LDAP + Squirrelmail. Everything seems to work, except for receiving mails. The FQDN is configured to be say example.com and I send an email to vijaykumar@example.com, from my login (vijaykumar) using squirrelmail. The email recipient address gets converted to "vijaykumar @ example.com", after a lookup in the Global Address Book, by Citadel, and eventually returns with the error message "Invalid recepient: vijaykumar @ example.com". So while I am able to send mails to other servers, I am not able receive mails or send mails within the server.

OK, got this fixed. The problem was with the Citadel node name. We had specified the node name as "example.com". This had caused citadel addresses to be treated as internet addresses. Changing the node name to "example" fixed the issue.

Regards,

Vijay



[#] Tue Aug 29 2017 09:10:20 EDT from xnukes @ Uncensored

Subject: install on debian jessie

[Reply] [ReplyQuoted] [Headers] [Print]

hello , please help me. I have add repository into apt sources list and execute apt-get update. this is finish on "Selhalo stažení http://debian.citadel.org/debian/dists/jessie/main/binary-i386/Packages  404  Not Found"

My linux version is Debian Jessie 8 - x64. Thanks



[#] Tue Aug 29 2017 11:17:39 EDT from bennabiy @ Uncensored

Subject: Re: install on debian jessie

[Reply] [ReplyQuoted] [Headers] [Print]

Please use the Easy Install method, rather than the repository. Much better and more stable support in Jessie.

http://www.citadel.org/doku.php?id=installation:easyinstall:start

Tue Aug 29 2017 09:10:20 AM EDT from xnukes @ Uncensored Subject: install on debian jessie

hello , please help me. I have add repository into apt sources list and execute apt-get update. this is finish on "Selhalo stažení http://debian.citadel.org/debian/dists/jessie/main/binary-i386/Packages  404  Not Found"

My linux version is Debian Jessie 8 - x64. Thanks



 



[#] Tue Aug 29 2017 14:04:22 EDT from apox13 @ Uncensored

Subject: Re: Easy install problem

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for replay!

Now I have an other compilation error, found anything on the web or forum about:

 

modules/crypto/serv_crypto.c:147:22: error: dereferencing pointer to incomplete type 'DH {aka struct dh_st}'
  if (!(BN_hex2bn(&(dh->p), DH_P))) {
                      ^~
modules/crypto/serv_crypto.c:173:3: warning: 'RSA_generate_key' is deprecated [-Wdeprecated-declarations]
   rsa = RSA_generate_key(1024, /* modulus size */
   ^~~
In file included from /usr/include/openssl/rsa.h:13:0,
                 from /usr/include/openssl/x509.h:31,
                 from /usr/include/openssl/ssl.h:50,
                 from modules/crypto/serv_crypto.c:20:
/usr/include/openssl/rsa.h:193:1: note: declared here
 DEPRECATEDIN_0_9_8(RSA *RSA_generate_key(int bits, unsigned long e, void
 ^
modules/crypto/serv_crypto.c:305:35: error: dereferencing pointer to incomplete type 'X509_REQ {aka struct X509_req_st}'
      X509_set_issuer_name(cer, req->req_info->subject);
                                   ^~
In file included from /usr/include/openssl/ssl.h:48:0,
                 from modules/crypto/serv_crypto.c:20:
modules/crypto/serv_crypto.c: In function 'CtdlStartTLS':
modules/crypto/serv_crypto.c:637:23: error: dereferencing pointer to incomplete type 'SSL {aka struct ssl_st}'
  BIO_set_close(CC->ssl->rbio, BIO_NOCLOSE);
                       ^
At top level:
modules/crypto/serv_crypto.c:61:22: warning: 'id_callback' defined but not used [-Wunused-function]
 static unsigned long id_callback(void)
                      ^~~~~~~~~~~
Makefile:145: recipe for target 'modules/crypto/serv_crypto.o' failed
make: *** [modules/crypto/serv_crypto.o] Error 1
Operating system: Linux Debian 9.1 ( 4.9.0-3-686-pae i686)

 

Many thanks

Alain

 

Sun Aug 27 2017 15:45:05 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Easy install problem
lib/stringbuf.c:2846:2: error: unknown type name 'z_stream'
  z_stream zstream;
  ^~~~~~~~

Install zlib and zlib-devel (or zlib-dev). That should fix the build.

 



[#] Wed Aug 30 2017 12:15:37 EDT from Maria @ Uncensored

Subject: Re: Mail Aliases not beeing saved

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Aug 28 2017 12:17:24 EDT from Maria @ Uncensored Subject: Mail Aliases not beeing saved

(newest Version over Easy Install)

 

Hi, another small Problem:

When I enter an E-Mail Alias into the Vcard of the user and hit save... it`s not been saved!

Not sure why... everything else, for example Fax, Telephone, Name is saved...

I found the file "mail.aliases" and made the changes there... but not shure about the syntax there, how to make one Mail Alias for 4 Users (so 3 Users share the same alias)

Checked also the permissions of the file "mail.aliases", seems to be OK (staff > 644)

ThX for any Help :)

Maria



Hi... Could anybody help me with this?

Or how is the right Syntax for the "mail.aliases" File?

I`m using:

test@domain.com, user1

 

Thanks in advance.. ;)



[#] Wed Aug 30 2017 14:25:48 EDT from jfinn @ Uncensored

Subject: Re: Installation of Apache AFTER Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Sep 05 2016 18:29:03 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Installation of Apache AFTER Citadel

Feh! Put Apache on the other port. We were on 80 first! :)

There are also a couple more options.

1. If your web server can be given multiple IP addresses, you can have Citadel listen on one and Apache on another.

2. If your web server only has one IP address but can be given multiple hostnames, you can use a combination of NameVirtualHost and Proxy to mix them together.
This strategy is outlined at [ http://www.citadel.org/doku.php/faq:installation:apacheproxy ].

Using a different port number is still the cleanest option, though.

I'm actually have a pretty similar problem. I tried to move Webcit to port 88 and somehow foobar'd the internal port bind for the Citadel server, 504/tcp. Now, when I launch the citadel server and check netstat, I don't see the port bind for 504 to 0.0.0.0

I've tried looking at the config file at /etc/init.d/citadel and that points to a file that is supposed to be in /etc/default/$NAME (citserver), but that file doesn't exist.

I've also manually installed the network service line(Citadel(doesn't need to be caps, right?) 504 TCP) in the /etc/services file and restarted the server multiple times, made sure the line persisted in the file, etc, etc, etc, and I still can't get that 504 port to bind when I start the server.

 

Ideas? No clue how I ef'd this thing up, but I did purge and instll webcit, citadel-suite, and citadel-server about 20 times to try and get webcit to work the way I wanted (which I believe I have now). All I know is it started spitting an error message about port 504 isn't specified and it should be -1 or specify a valid TCP port (c_port_number) and I can't figure out where to specify that!

 

Thanks!



[#] Wed Aug 30 2017 14:58:48 EDT from jfinn @ Uncensored

Subject: Re: Installation of Apache AFTER Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Sep 05 2016 18:29:03 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Installation of Apache AFTER Citadel

Feh! Put Apache on the other port. We were on 80 first! :)

There are also a couple more options.

1. If your web server can be given multiple IP addresses, you can have Citadel listen on one and Apache on another.

2. If your web server only has one IP address but can be given multiple hostnames, you can use a combination of NameVirtualHost and Proxy to mix them together.
This strategy is outlined at [ http://www.citadel.org/doku.php/faq:installation:apacheproxy ].

Using a different port number is still the cleanest option, though.

I'm actually have a pretty similar problem. I tried to move Webcit to port 88 and somehow foobar'd the internal port bind for the Citadel server, 504/tcp. Now, when I launch the citadel server and check netstat, I don't see the port bind for 504 to 0.0.0.0

I've tried looking at the config file at /etc/init.d/citadel and that points to a file that is supposed to be in /etc/default/$NAME (citserver), but that file doesn't exist.

I've also manually installed the network service line(Citadel(doesn't need to be caps, right?) 504 TCP) in the /etc/services file and restarted the server multiple times, made sure the line persisted in the file, etc, etc, etc, and I still can't get that 504 port to bind when I start the server.

 

Ideas? No clue how I ef'd this thing up, but I did purge and instll webcit, citadel-suite, and citadel-server about 20 times to try and get webcit to work the way I wanted (which I believe I have now). All I know is it started spitting an error message about port 504 isn't specified and it should be -1 or specify a valid TCP port (c_port_number) and I can't figure out where to specify that!

 

Thanks!



[#] Wed Aug 30 2017 15:24:14 EDT from jfinn @ Uncensored

Subject: Re: need to change webcit address

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Sep 14 2016 08:40:42 EDT from hubertus @ Uncensored Subject: Re: need to change webcit address

 

Mon Sep 12 2016 10:42:43 EDT from romeske @ Uncensored Subject: need to change webcit address

I recently changed the IP address under global settings via the web interface to the local IP address of the machine. It used to be 0.0.0.0. After doing this, i now receive the message "This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.". How do I change the IP address back to 0.0.0.0, and is what I changed even the issue? I am still able to use my imap client to send and receive emails fine.

 

Thank you



 

I'm on the packaged version on a ubuntu 16-04 LTS machine and have the same or similar issue.
For me it seems that everytime I make changes under Administration/Site Wide Configuration Webcit looses the port number 504 an tries to connect on port 0 after a restart.
However running /usr/lib/citadel-server/setup an changing the port back to 504 solves the issue.

Is this a bug or a missing configuration entry somewhere ?

Thanks for any hints



Disregard my previous, This looks like the key!



[#] Thu Aug 31 2017 10:41:26 EDT from the-cox @ Uncensored

Subject: Feature or security issue ....

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Support,

i just discovered, that an admin is able to discover the passwords of other users on the html page source code...

If an admin goes to"Add, change, delete user accounts" and than edit configuration of an user and looks into the source-code, the password is filled in there.

Is this a feature? shouldn't be the password field blank, so that the administrator could change the new password, but not read the old password?

Cheers,

Jan the-cox



[#] Fri Sep 01 2017 11:20:41 EDT from Freakdog @ Dog Pound BBS II

Subject: Re: Feature or security issue ....

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Aug 31 2017 10:41:26 AM EDT from the-cox @ Uncensored Subject: Feature or security issue ....

Hi Support,

i just discovered, that an admin is able to discover the passwords of other users on the html page source code...

If an admin goes to"Add, change, delete user accounts" and than edit configuration of an user and looks into the source-code, the password is filled in there.

Is this a feature? shouldn't be the password field blank, so that the administrator could change the new password, but not read the old password?

Cheers,

Jan the-cox

Interesting...in which browser are you seeing this?

I tried it using Chrome and, after telling me that it had to resubmit the "form", I saw no info about the account in question in the page source, at all.



[#] Fri Sep 01 2017 11:23:34 EDT from Freakdog @ Dog Pound BBS II

Subject: Re: Feature or security issue ....

[Reply] [ReplyQuoted] [Headers] [Print]

Another question would be:

  • In which version of Citadel and Webcit are you noting this behavior?


[#] Fri Sep 01 2017 12:10:54 EDT from s3cr3to @ Uncensored to Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Feature or security issue ....

[Reply] [ReplyQuoted] [Headers] [Print]

And an evil browser addon can read the source code of the page and
harvest the user/password. yikes! Or a malware/trojan can be running
just waiting for temporary cached pages. This can be ugly.

Time to learn how to manage our user accounts from the terminal client.
And leave the browser for this tasks?

This is version 8.17

On 09/01/2017 09:23 AM, Freakdog wrote:
Another question would be:

* In which version of Citadel and Webcit are you noting this behavior?

[#] Fri Sep 01 2017 22:37:24 EDT from Freakdog @ Dog Pound BBS II

Subject: Re: Feature or security issue ....

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Sep 01 2017 12:10:54 PM EDT from s3cr3to @ Uncensored Subject: Re: Feature or security issue ....
And an evil browser addon can read the source code of the page and
harvest the user/password. yikes! Or a malware/trojan can be running
just waiting for temporary cached pages. This can be ugly.

Time to learn how to manage our user accounts from the terminal client.
And leave the browser for this tasks?

This is version 8.17

On 09/01/2017 09:23 AM, Freakdog wrote:
Another question would be:

* In which version of Citadel and Webcit are you noting this behavior?

8.17 is pretty old, at this point.

I'm not saying that the issue won't surface if you do so, but I recommend upgrading to the latest release.



Go to page: First ... 117 118 119 120 [121] 122 123 124 125