Language:
switch to room list switch to menu My folders
Go to page: First ... 102 103 104 105 [106] 107 108 109 110 ... Last
[#] Thu May 18 2017 11:51:50 EDT from ola @ Uncensored

Subject: Re: Citadel on Ubuntu Server 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I have nothing installed in my server rather than Citadel. You can find attached what I get when I run: service citadel status



cit-error.PNG (image/png, 36921 bytes) [ View | Download ]
[#] Thu May 18 2017 12:21:56 EDT from heini @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu May 18 2017 03:11:33 EDT from graylion @ Uncensored Subject: installing on Ubuntu 16.04

> nano /etc/init.de/webcit


add

### BEGIN INIT INFO
# Provides:          webcit
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start daemon at boot time
# Description:       Enable service provided by daemon.
### END INIT INFO
 
could this be incorporated into the product please?

Err, since Ubuntu16.04 uses systemd, it'd be better to provide proper unit files.

 

Bye...

 

    Heini



[#] Fri May 19 2017 03:07:52 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I tried to add this in the webcit file, nothing changed, I'm getting the same error. I don't understand how just changing the timezone causes this error, isn't this a bug? 



[#] Sat May 20 2017 15:25:34 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Can somebody help me with this error please? Looks like everything that I edit in the Edit Site Wide Configuration breaks the communication of webcit with the citadel server and I get the error:  This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.  I've installed Citadel in Ubuntu Server 16.04, I'm running Citadel 9.01, Webcit 9.01. I would really appreciate your help!!! 



[#] Sat May 20 2017 20:07:34 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Did you install with packages from the repository, or from Easy Install?

Sat May 20 2017 03:25:34 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

Can somebody help me with this error please? Looks like everything that I edit in the Edit Site Wide Configuration breaks the communication of webcit with the citadel server and I get the error:  This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.  I've installed Citadel in Ubuntu Server 16.04, I'm running Citadel 9.01, Webcit 9.01. I would really appreciate your help!!! 



 



[#] Sat May 20 2017 20:15:44 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I installed it running: sudo apt-get install citadel-webcit citadel-server citadel-mta, also tried sudo apt-get install citadel-suite, but not with Easy Install



[#] Sat May 20 2017 21:51:08 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I did a test installing Citadel with Easy Install locally and it is not giving me the error. But how can I do now to fix my real server's installation, I don't want to install it from the beginning, I have data that I don't want to lose. 

In my real server I have not installed : apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev     . Can the error be caused by the absence of this installation?


 

 



[#] Sat May 20 2017 23:22:29 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I did a test installing Citadel with Easy Install locally and it is not giving me the error. But how can I do now to fix my real server's installation, I don't want to install it from the beginning, I have data that I don't want to lose. 

In my real server I have not installed : apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev     . Can the error be caused by the absence of this installation?


 

 



[#] Sat May 20 2017 23:38:58 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Looks like installing Citadel from the repository with sudo apt-get install citadel-suite on Ubunutu 16.04 amd64 has some kind of bug, maybe something is missing. I'm not getting the error with the installation from Easy Install. How can I fix this?



[#] Sun May 21 2017 09:29:19 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

It is hard to say what the original cause is, except that there is something different being done by the packages in the repository vs easy install actually checking to make sure it has what it needs on your system to work well. Plus easy install is kept all in one location (relatively) and is a little easier to debug because of that.

Sat May 20 2017 09:51:08 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

I did a test installing Citadel with Easy Install locally and it is not giving me the error. But how can I do now to fix my real server's installation, I don't want to install it from the beginning, I have data that I don't want to lose. 

In my real server I have not installed : apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev     . Can the error be caused by the absence of this installation?


 

 



 



[#] Sun May 21 2017 09:30:08 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Use easy install and migrate your information from one install to the other (look in the documentation online, there is info on it.)

Sat May 20 2017 11:38:58 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

Looks like installing Citadel from the repository with sudo apt-get install citadel-suite on Ubunutu 16.04 amd64 has some kind of bug, maybe something is missing. I'm not getting the error with the installation from Easy Install. How can I fix this?



 



[#] Sun May 21 2017 10:15:42 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I was looking in the forum here and found a solution about the error. Looks like somehow when making changes in the Edit side-wide configuration Webcit loses the port number 504 an tries to connect on port 0 after a restart. If you run /usr/lib/citadel-server/setup as root and set the port to 504 again, it fixes the error. Anyway you're referring to this doc: http://www.citadel.org/doku.php/faq:systemadmin:how_do_i_move_citadel_to_another_host?s[]=move&s[]=one&s[]=installation&s[]=another     to move the installation to another? Thanks



[#] Sun May 21 2017 12:18:03 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

http://www.citadel.org/doku.php/faq:systemadmin:how_do_i_move_citadel_to_another_host looks right. That would probably be the easiest (with you running one on a different set of ports, then adjusting the settings afterwards)

Sun May 21 2017 10:15:42 AM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

I was looking in the forum here and found a solution about the error. Looks like somehow when making changes in the Edit side-wide configuration Webcit loses the port number 504 an tries to connect on port 0 after a restart. If you run /usr/lib/citadel-server/setup as root and set the port to 504 again, it fixes the error. Anyway you're referring to this doc: http://www.citadel.org/doku.php/faq:systemadmin:how_do_i_move_citadel_to_another_host?s[]=move&s[]=one&s[]=installation&s[]=another     to move the installation to another? Thanks



 



[#] Mon May 22 2017 06:15:41 EDT from feivel @ Uncensored

Subject: external smtp

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

is there a way to make sure citadel-server does not bind to port 25 during setup? I would have thought  setting ACT_AS_MTA to no before running setup should accomplish this, but alas it does not seem to. 

I've been trying to do this with 902, so it may have been changed in later versions.



[#] Mon May 22 2017 12:28:05 EDT from Freejack @ Uncensored

Subject: Citadel replication

[Reply] [ReplyQuoted] [Headers] [Print]

I have to Citadel servers setup. I have been trying to get replication to work to no avail. One is version 9.01 and the other is 9.11. When I put them in Network Configuration they both go in fine. Using port 504 which is open on both firewalls. Set to transfer every 3600 seconds (1hr) and they have not even sent the simple posted test message in the room that is on both ends and shared on both. Any ideas?



[#] Mon May 22 2017 15:33:26 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel replication

[Reply] [ReplyQuoted] [Headers] [Print]

901 and 911 should speak to each other without any problem. Do make sure that the systems have each other set up in their network configurations and are using the same host names, shared secret, etc.

Also be sure that the room sharing is configured identically on both systems.

Finally, I do hope that you're attempting to share a normal room and not a private mailbox. If the room only exists in one user's namespace, it won't behave as you expect when you try to share it.

[#] Mon May 22 2017 15:35:18 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I was looking in the forum here and found a solution about the error. Looks

like somehow when making changes in the Edit side-wide configuration Webcit

loses the port number 504 an tries to connect on port 0 after a restart.
If

This was a known bug and was fixed not too long ago. If you're not running the latest code please upgrade.

[#] Mon May 22 2017 15:34:25 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: external smtp

[Reply] [ReplyQuoted] [Headers] [Print]

is there a way to make sure citadel-server does not bind to port 25
during setup? I would have thought  setting ACT_AS_MTA to no before
running setup should accomplish this, but alas it does not seem to. 

During setup, no. You will have to fire up Citadel Server at least once and then turn it off.

[#] Mon May 22 2017 15:48:51 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Looks like installing Citadel from the repository with sudo apt-get
install citadel-suite on Ubunutu 16.04 amd64 has some kind of bug,
maybe something is missing. I'm not getting the error with the
installation from Easy Install. How can I fix this?

The obviously snarky answer is ... use Easy Install :)

Seriously though, the packages are getting kind of outdated, and unfortunately we depend on both the package maintainers and the timing of OS releases for them, both of which are out of the control of the core team. That's kind of why Easy Install exists, to make the latest-and-greatest available to everyone without having to force everyone to learn how to do a manual build. In the future we might add a Docker image to do the same thing.

[#] Mon May 22 2017 17:18:14 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Thank you for your help :) Also I guess Citadel runs smoothly even with a lot of users for example 100 or more?



Go to page: First ... 102 103 104 105 [106] 107 108 109 110 ... Last