Language:
switch to room list switch to menu My folders
Go to page: First ... 101 102 103 104 [105] 106 107 108 109 ... Last
[#] Sun Mar 26 2017 12:40:57 EDT from Matty @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I cant send messages from gmail to my citadel/ Please help



[#] Sun Mar 26 2017 16:09:21 EDT from bennabiy @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Matty, can you provide more information? 

Sun Mar 26 2017 12:40:57 PM EDT from Matty @ Uncensored

I cant send messages from gmail to my citadel/ Please help



 



[#] Mon Mar 27 2017 15:44:38 EDT from heini @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Mar 26 2017 11:54:25 EDT from heini @ Uncensored Subject: Can't resolve admin account from AD

Hi,

just did a fresh setup with Debian packages (version 902) on Stretch and configured it to use a Samba 4 AD for authentication. I've created an admin user in AD called citadm and made sure to omit first/last name attributes. The machine is also joined to to the domain and I can locally resolve that user with "id citadm".

 

Now, when I try to login using the CLI client, I get this:

# citadel
Attaching to server...
Citadel 902              
Citadel Server
(null)
pause    next    stop
ctrl-s  ctrl-o  ctrl-c

 
Welcome to Citadel Server!
 
This logon banner resides in /etc/citadel/messages//hello -- please customize it for your site.
  

Enter your name: citadm
'citadm' not found.
Type 'off' if you would like to exit.
Enter your name: off
off logged out.


I also find this in the log:


Mär 26 17:27:17 citadel citserver[11119]: New client socket 41
Mär 26 17:27:17 citadel citserver[11119]: Session (citadel-UDS) started via local socket UID:0.
Mär 26 17:27:17 citadel citserver[11119]: Client 0/0/8.11 (local) from console
Mär 26 17:27:21 citadel citserver[11119]: LDAP bind DN: CN=binduser,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: LDAP search: (sAMAccountName=citadm)
Mär 26 17:27:21 citadel citserver[11119]: dn = CN=citadm,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: uid hashed from objectGUID = 808751882
Mär 26 17:27:21 citadel citserver[11119]: LDAP bind DN: CN=binduser,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: LDAP search: (sAMAccountName=citadm)
Mär 26 17:27:21 citadel citserver[11119]: dn = CN=citadm,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: uid hashed from objectGUID = 808751882
Mär 26 17:28:36 citadel citserver[11119]: Closing socket 41
Mär 26 17:28:36 citadel citserver[11119]: W Context: [  6]SRV[citadel-UDS] Session ended.

BTW: There's also this message: configuration setting c_default_cal_zone is empty, but must not - check your config!

Could this be related? How do I fix it anyway?

 

Bye...

 

    Heini

 



[#] Tue Mar 28 2017 11:00:06 EDT from bennabiy @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

You may want to try the easy install as there have been some changes made between versions (and the debian packages are not the most current stable).

Mon Mar 27 2017 03:44:38 PM EDT from heini @ Uncensored Subject: Re: Can't resolve admin account from AD

 

Sun Mar 26 2017 11:54:25 EDT from heini @ Uncensored Subject: Can't resolve admin account from AD

Hi,

just did a fresh setup with Debian packages (version 902) on Stretch and configured it to use a Samba 4 AD for authentication. I've created an admin user in AD called citadm and made sure to omit first/last name attributes. The machine is also joined to to the domain and I can locally resolve that user with "id citadm".

 

Now, when I try to login using the CLI client, I get this:

# citadel
Attaching to server...
Citadel 902              
Citadel Server
(null)
pause    next    stop
ctrl-s  ctrl-o  ctrl-c

 
Welcome to Citadel Server!
 
This logon banner resides in /etc/citadel/messages//hello -- please customize it for your site.
  

Enter your name: citadm
'citadm' not found.
Type 'off' if you would like to exit.
Enter your name: off
off logged out.


I also find this in the log:


Mär 26 17:27:17 citadel citserver[11119]: New client socket 41
Mär 26 17:27:17 citadel citserver[11119]: Session (citadel-UDS) started via local socket UID:0.
Mär 26 17:27:17 citadel citserver[11119]: Client 0/0/8.11 (local) from console
Mär 26 17:27:21 citadel citserver[11119]: LDAP bind DN: CN=binduser,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: LDAP search: (sAMAccountName=citadm)
Mär 26 17:27:21 citadel citserver[11119]: dn = CN=citadm,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: uid hashed from objectGUID = 808751882
Mär 26 17:27:21 citadel citserver[11119]: LDAP bind DN: CN=binduser,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: LDAP search: (sAMAccountName=citadm)
Mär 26 17:27:21 citadel citserver[11119]: dn = CN=citadm,CN=Users,DC=altum,DC=de
Mär 26 17:27:21 citadel citserver[11119]: uid hashed from objectGUID = 808751882
Mär 26 17:28:36 citadel citserver[11119]: Closing socket 41
Mär 26 17:28:36 citadel citserver[11119]: W Context: [  6]SRV[citadel-UDS] Session ended.

BTW: There's also this message: configuration setting c_default_cal_zone is empty, but must not - check your config!

Could this be related? How do I fix it anyway?

 

Bye...

 

    Heini

 



 



[#] Tue Mar 28 2017 11:20:33 EDT from heini @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

Tue Mar 28 2017 11:00:06 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

You may want to try the easy install as there have been some changes made between versions (and the debian packages are not the most current stable).

Tried that already, but it failed to compile.

Bye...

 

    Heini



[#] Tue Mar 28 2017 11:41:18 EDT from bennabiy @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

Did you install the dependencies and follow the directions for debian? I currently have about 5 citadel installs all happily running on debian (from wheezy to Jessie) all using LDAP.

Tue Mar 28 2017 11:20:33 AM EDT from heini @ Uncensored Subject: Re: Can't resolve admin account from AD

Hi,

Tue Mar 28 2017 11:00:06 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

You may want to try the easy install as there have been some changes made between versions (and the debian packages are not the most current stable).

Tried that already, but it failed to compile.

Bye...

 

    Heini



 



[#] Tue Mar 28 2017 13:11:58 EDT from heini @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Mar 28 2017 11:41:18 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

Did you install the dependencies and follow the directions for debian?

Yes, I did.

 I currently have about 5 citadel installs all happily running on debian (from wheezy to Jessie) all using LDAP.

 This is a Stretch system, and it's AD, not standard LDAP.

 

Bye...

 

    Heini



[#] Tue Mar 28 2017 17:11:18 EDT from bennabiy @ Uncensored

Subject: Error with IMAP implementation

[Reply] [ReplyQuoted] [Headers] [Print]

IMAP FETCH command is being divided causing issues on some mail clients. Posted below is the debug output from one (emphasis added).

 

[imapx:A] I/O: '* 1 FETCH (UID 145342 RFC822.SIZE 3918 ^M

RFC822.HEADER {247}^M

Return-Path: userb@example.net^M

Date: Sun, 29 Jan 2017 11:35:31 -0500^M

To: usera@example.net^M

Subject: Test^M

Message-ID: <da4845f637bf1b3494037561af73468f@example.net>^M

From: "User B" <userb@example.net>^M

 FLAGS (\Seen))^M

 

 



[#] Tue Mar 28 2017 17:46:32 EDT from Freakdog @ Dog Pound BBS II

[Reply] [ReplyQuoted] [Headers] [Print]

Just a note...I updated to 907 using Easy Install...the process replaced my hello and goodbye files with the stock files.

This is the first time that this has happened in quite a long time.



[#] Wed Mar 29 2017 09:32:07 EDT from bennabiy @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I noted the same thing. 

Tue Mar 28 2017 05:46:32 PM EDT from Freakdog @ Dog Pound BBS II

Just a note...I updated to 907 using Easy Install...the process replaced my hello and goodbye files with the stock files.

This is the first time that this has happened in quite a long time.



 



[#] Wed Mar 29 2017 19:10:54 EDT from tank100 @ Uncensored

Subject: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

I can't seem to send or receive mail from external sources.  I have port forwarded port 25 and my isp claims that they have unblocked it; so any suggestions?



[#] Thu Mar 30 2017 03:31:15 EDT from jsebean @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

Well they didn't unblock it then. ;)

Wed Mar 29 2017 19:10:54 EDT from tank100 @ Uncensored Subject: Sending and receiving

I can't seem to send or receive mail from external sources.  I have port forwarded port 25 and my isp claims that they have unblocked it; so any suggestions?



 



[#] Thu Mar 30 2017 06:27:49 EDT from graylion @ Uncensored

Subject: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

Hi guys

I am following http://www.citadel.org/doku.php/installation:easyinstall:prereq-debian.html and the download works and I get through the options and no problems. But then it tries to restart the server and hangs at 95%. I have sufficient disk space.

The end of /tmp/citadel-install-log.txt reads:

 

2017-03-30 03:16:34 (9.15 MB/s) - 'webcit-easyinstall.sum' saved [41/41]

--2017-03-30 03:16:34--  http://easyinstall.citadel.org/textclient-easyinstall.sum
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 41 [text/plain]
Saving to: 'textclient-easyinstall.sum'

     0K                                                       100% 11.2M=0s

2017-03-30 03:16:34 (11.2 MB/s) - 'textclient-easyinstall.sum' saved [41/41]

--2017-03-30 03:16:34--  http://easyinstall.citadel.org/citadel-init-scripts.tar
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10240 (10K) [application/x-tar]
Saving to: 'citadel-init-scripts.tar'

     0K ..........                                            100% 22.6K=0.4s

2017-03-30 03:16:35 (22.6 KB/s) - 'citadel-init-scripts.tar' saved [10240/10240]

Operating system: Linux Debian stretch/sid ( 4.4.0-66-generic x86_64)

Any ideas? And many thanks in advance!

 



[#] Thu Mar 30 2017 07:03:06 EDT from graylion @ Uncensored

Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

sorted - it did not like LDAP as authentication :(



[#] Thu Mar 30 2017 09:21:16 EDT from warbaby @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

telnet to port 25 on your box and see what happens

Wed Mar 29 2017 07:10:54 PM EDT from tank100 @ Uncensored Subject: Sending and receiving

I can't seem to send or receive mail from external sources.  I have port forwarded port 25 and my isp claims that they have unblocked it; so any suggestions?



 



[#] Thu Mar 30 2017 12:11:10 EDT from graylion @ Uncensored

Subject: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



[#] Thu Mar 30 2017 12:29:04 EDT from bennabiy @ Uncensored

Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

For LDAP authentication to work, you need to have libldap2-dev installed on a debian or ubuntu system (not sure package on others)...

 

That needs to be installed before you run the easy install scripts. 

Thu Mar 30 2017 07:03:06 AM EDT from graylion @ Uncensored Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

sorted - it did not like LDAP as authentication :(



 



[#] Thu Mar 30 2017 12:31:07 EDT from bennabiy @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

This is a known issue (although not entirely known WHY it happens ) but to fix it with an easy install:

sudo ~citadel/setup

will rerun through the setup of citserver and one of the entries is the port.

Thu Mar 30 2017 12:11:10 PM EDT from graylion @ Uncensored Subject: c_port_number

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



 



[#] Thu Mar 30 2017 23:22:33 EDT from kc5tja @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I've been kicking around the idea of setting up a Citadel instance for myself and my friends to use (Twitter just makes more and more and more stupid ideas reality, pushing me and my group that much closer to wanting our own local forum). The last time I set up a Citadel instance on a cloud server, it ended up forwarding spam every which way, and I had to shut it down.
Any one have a collection of howto's or other resources on how to secure a Citadel instance? (Point of reference; package in Ubuntu is 9.01; I know it's not the latest, but it's the easiest for me to configure for hopefully obvious reasons.)

Thanks.

[#] Fri Mar 31 2017 04:29:03 EDT from graylion @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks, that worked



Go to page: First ... 101 102 103 104 [105] 106 107 108 109 ... Last