Language:
switch to room list switch to menu My folders
Go to page: First ... 62 63 64 65 [66] 67 68 69 70 ... Last
[#] Sat Sep 05 2015 15:07:06 EDT from cleansound @ Uncensored

Subject: Calendar events and Attendees

[Reply] [ReplyQuoted] [Headers] [Print]

I recently stumbled across Citadel, so this is my first experience.  I installed Citadel+Webcit 8.24 to play with on a fresh Debian Jessie vbox guest, from apt-get, and so far I'm only using webcit to interact with it.  I have set all of the SMTP/POP/IMAP global settings to -1 (from inside webcit) because we don't need an email server, we mostly want a reference calendar, contacts, and a forum for project discussion. 

As an organization, our biggest current need is a master calendar we can view in-browser, where the boss can add events, assign people to them, and the rest of the users can view it.  Being able to check availability against a personal calendar would be a big plus.  Citadel seems to have all these abilities, but in my first attempts I can't seem to make the "Attendees" part of an event work.

I created a room called Master Calendar in floor 0.  If I create a new event in this calendar and tab over to Attendees, I can't seem to add them.  I made the Global Address Book public (because my test users aren't listed in the other contacts menus), and I am choosing "test1 <test1@citadel>"  and trying to add that user.  The username shows up in the Attendees box, but clicking "Check attendee availability" does nothing, and I can't select test1 in the Attendees box.  If I click "Save" it will update other info about the event, but not attendees I tried to add.

I assume I'm doing something wrong, any help?  I was hoping the event would pop up on the user's personal calendar, and ideally show a conflict with the user's personal calendar if it exists.



[#] Sat Sep 05 2015 22:24:22 EDT from "Sebastian Pipping" <sebastian@pipping.org> to citadel_support@citadel.org

Subject: Bug report: Citadel configure script --with-with_*

[Reply] [ReplyQuoted] [Headers] [Print]

Hi!


The configure script of Citadel advertises options

--with-ldap
(--with-libdspam)
--with-gc

but the related code

AC_ARG_WITH(with_ldap, .........
dnl AC_ARG_WITH(with_libdspam, ........
AC_ARG_WITH(with_gc, ........

makes them end up as

--with-with_ldap
(--with-with_libdspam)
--with-with_gc

For proof see:

# fgrep with_with configure
with_with_ldap
with_with_gc
if test "${with_with_ldap+set}" = set; then :
withval=$with_with_ldap;
if test "${with_with_gc+set}" = set; then :
withval=$with_with_gc;

I suppose it's unintentional. Would you accept a patch?

Best,



Sebastian


PS: It seems there has been a bug tracker at bugzilla.citadel.org,
previously. Has it been moved? If the docs say where to report bugs
to, I didn't find it.

[#] Sun Sep 06 2015 04:33:05 EDT from jakov @ Uncensored

Subject: Attachments frequently CORRUPTED

[Reply] [ReplyQuoted] [Headers] [Print]

Hello there!

 

Let me first say that I am so impressed with how simple Citadel was to set up. Especially after failing to setup some other groupware solutions on Linux.

 

However, now it has happened several times that attachments have become corrupted. Both attachments I have sent, and attachments I have received from gmail accounts. It makes no apparent difference if I used webcit or an IMAP client (OSX Mail and Thunderbird).

A casual inspection of received PDFs with "vim", gives that there seems to be a lot of ^M newlines sprinkled inside the PDF?

 

However, this problem does not happen all the time. I have not managed to intentionally reproduce it by just sending a random PDF to myself, for instance.

 

But images frequently are corrupted, to the point that I no longer email images from my smartphone, because the risk of failure is high.

 

Does anyone have experience with attachment corruption?   I don't know if it's relevant, but I run Citadel on a raspberry pi with an SSD attached.



[#] Sun Sep 06 2015 15:40:17 EDT from dothebart @ Uncensored

Subject: Re: Bug report: Citadel configure script --with-with_*

[Reply] [ReplyQuoted] [Headers] [Print]

the dspam module was nowhere near what one could call alpha. If you want to work on it, yes, patches welcome. elsewes its just rm -rf if you insist.



[#] Sun Sep 06 2015 15:43:34 EDT from "Sebastian Pipping" <sebastian@pipping.org> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Re: Bug report: Citadel configure script--with-with_*

[Reply] [ReplyQuoted] [Headers] [Print]

On 06.09.2015 21:40, dothebart wrote:
the dspam module was nowhere near what one could call alpha. If you want
to work on it, yes, patches welcome. elsewes its just rm -rf if you insist.


I'm aware that the dspam lines are commented out. It's not really about
dspam. It's about the names of the configure switches.



Sebastian

[#] Mon Sep 07 2015 07:54:19 EDT from "Sebastian Pipping" <sebastian@pipping.org> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Attachments frequently CORRUPTED

[Reply] [ReplyQuoted] [Headers] [Print]

On 06.09.2015 10:33, jakov wrote:
I don't know
if it's relevant, but I run Citadel on a raspberry pi with an SSD attached.

A friend of mine had corruption problems with Raspberries and an SD
card. Key question could be if you turn it on and off frequently and if
you use a file system with journaling (e.g. ext3/4) or not (e.g. ext2).
If you have an old unused notebook around, you could try with that for
a while instead.

Best,



Sebastian

[#] Sat Sep 12 2015 03:03:53 EDT from kiwols @ Uncensored

Subject: Re: Outbound mail beeing stuck without error

[Reply] [ReplyQuoted] [Headers] [Print]

Has anyone found a resolution to this probelm?

I am getting the same problem with mail sent to AOL, gmail, and similar addresses.

The email gets stuck in the queue with a Dec 31 1969 Next Attempt date.

It will finally send when I click Restart Now to reboot the Citadel server.

Any input would be greatly appreciated.

 

Thu Apr 16 2015 04:36:39 EDT from dothebart @ Uncensored Subject: Re: Outbound mail beeing stuck without error

Ok, that gives a good point.

What you're noting is probably greylisting. Greylisting sends the SMTP code for currently unavailable come back later. The SMTP conversation is closed with not sending the mail, but as the protocol describes.

Your case however is different: The conversation is stuck somewhere in mid-air. This rather sounds like a tar-pit or connection problems.

You can enable SMTP sending debugging; You should see the SMTP conversations in the syslog.

If that doesn't help, maybe running tcpdump with filtering for port 25 and the microsoft mailservers could bring us closer to the problem.

http://citadel.org/doku.php/faq:mastering_your_os:net_sniff#exploring.the.communication.from.your.citadel.server

Thu Apr 16 2015 03:02:46 EDT from Roknrol @ Uncensored Subject: Re: Outbound mail beeing stuck without error

Follow up with what I hope is additional relevant information.

Frequently the emails that fail to send are to MSN's servers.  If I delete the email from the mail queue, restart the mail server, and then resend it, it sends right away.  I note that MSN's servers seem to have ICMP replies disabled (no ping response, but servers are up).


In my digging last week, when I was researching the craigslist issue, I came across an "issue" where some email servers reject emails from smaller domains with the expectation that "legit" domains will just resend the emails (spammers are apparently too lazy to hit "resend").  I suspect that most email servers will automatically retry (and Citadel may, as well - I have no idea). 

This is an awfully big conclusion to leap to, but I think based on the lack of logged errors, that maybe the server isn't picking up on the failure/bounce/whatever so it's never triggered to actually resend?

I'm really out of my depth at this point and could use some direction from someone that knows more.


Thanks in advance

 

Mon Apr 13 2015 16:03:40 EDT from Roknrol @ Uncensored Subject: Re: Outbound mail beeing stuck without error

Hi Pusaken - I've been encountering a similar issue that may help someone volunteer some expertise.

My mail server almost always works perfectly - I regularly send emails to other domains without issue (gmail and Google-hosted domains, Amazon, Hotmail, etc), however I have now twice had an email message hang in my queue the way you describe below.  Both emails were sent to the @job.craigslist.org domain, and both sit in the queue.  I think mine may end up sending before yours because the date listed is 1969.  Anyway, when there's one email hung, almost all other emails sent *also* hang.  The last time this happened I had to actually delete everything in the queue before I could get anything to send. 

While troubleshooting this I encountered some information that points to a potential Reverse DNS configuration (although for me that was a red herring, it might be worth looking into for your issue).


Other than that, the only relevant errors that I can find in the logs say:

Apr 13 12:48:15 ****** citserver[2218]: SMTPCQ: Msg No 14767: already in progress!
Apr 13 12:48:15 ****** citserver[2218]: No external notifiers configured on system/user

Any assistance would be greatly appreciated.

Tue Mar 24 2015 05:09:53 EDTfrom pusaken @ Uncensored Subject: Outbound mail beeing stuck without error

Hello everyone,

I am having trouble with my outbound smtp-queue. Since my smarthost provider enforced higher security standards I had to switch to google. Therefore I changed my smarthost configuration acccordingly, and - after a message from google pointing out that a "less secure app" tried to send mail and was blocked - I lessened the google account preferences to allow less secure access.

But now the outbound smtp queue behaves oddly. New items are added with "next attempt" in Jan 1970 (which is ok I think) but they are not processed. Instead they sit there waiting for santa clause or someone else. There is no outbound error (like connection refused or connection interrupted, which I got while the smarthost was blocking citadel).

Actually one mail accidentially got sent tonight - I don't know why this one got through.

Is there a way to clean the message queue? When will a send attempt be made, when the date reads Jan 1970?

Might a complete configuration reset of citadel help? How can I accomplish that?

Thanks for your help,

kindest regards,

Pusaken



 



 



 



 



[#] Tue Sep 15 2015 10:07:43 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: How to truncate log files

[Reply] [ReplyQuoted] [Headers] [Print]

my lightly loaded system had over 32gb of transaction files. How do i
decrease the number of segments used? Is there a admin or command
line too to truncate/mark as backed up the logs?

There's an option in your system configuration to delete log files after they're committed.

[#] Thu Sep 17 2015 02:30:27 EDT from KissMyAsthma13 @ Uncensored

Subject: Citadel Rasberry Pi to XML

[Reply] [ReplyQuoted] [Headers] [Print]

Hello

 

Anyone knows how to export berkley citadel database to xml?

http://www.citadel.org/doku.php/installation:easyinstall:start

Used this guide and I can locate some files but how to actually export?

Also in step by step installation paths uses are not valid for my instant instalation

 

ty



[#] Thu Sep 17 2015 12:49:53 EDT from rolfijn @ Uncensored

Subject: firefox sec_error_reused_issuer_and_serial

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I tried today to access my Citadel installation at home but I got an error saying:

Secure Connection Failed

An error occurred during a connection to c.huttiesroow.nl. You have received an invalid certificate. Please contact the server administrator or email correspondent and give them the following information: Your certificate contains the same serial number as another certificate issued by the certificate authority. Please get a new certificate containing a unique serial number. (Error code: sec_error_reused_issuer_and_serial)

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

I use the certificates that were placed with the easy install. I am using Firefox 40.0.3 on Ubuntu 15.04. I think Firefox recently got updated and suppose that is where the error came from. If that is the case I am probably not alone in this?

Regards,

Rolf

 

PS. I just thought about using easy install to update my installation, perhaps that will help...



[#] Fri Sep 18 2015 01:24:28 EDT from rolfijn @ Uncensored

Subject: Re: firefox sec_error_reused_issuer_and_serial

[Reply] [ReplyQuoted] [Headers] [Print]

No, it didn't...

Thu Sep 17 2015 12:49:53 EDT from rolfijn @ Uncensored Subject: firefox sec_error_reused_issuer_and_serial

Hi,

I tried today to access my Citadel installation at home but I got an error saying:

Secure Connection Failed

An error occurred during a connection to c.huttiesroow.nl. You have received an invalid certificate. Please contact the server administrator or email correspondent and give them the following information: Your certificate contains the same serial number as another certificate issued by the certificate authority. Please get a new certificate containing a unique serial number. (Error code: sec_error_reused_issuer_and_serial)

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

I use the certificates that were placed with the easy install. I am using Firefox 40.0.3 on Ubuntu 15.04. I think Firefox recently got updated and suppose that is where the error came from. If that is the case I am probably not alone in this?

Regards,

Rolf

 

PS. I just thought about using easy install to update my installation, perhaps that will help...



 



[#] Fri Sep 18 2015 05:40:22 EDT from dothebart @ Uncensored

Subject: Re: firefox sec_error_reused_issuer_and_serial

[Reply] [ReplyQuoted] [Headers] [Print]

the reason here is, that citadel builds a fake CA, which then starts to issue certificates with #0.

Once you do that on a second place, it will build a similar CA, which also starts with #0 -> clash.

 

you can override them by setting these environment variables before starting webcit the 'first' time:

OU -> organizational Unit (defaults "Citadel server")

O -> Organization (defaults "Organization name")

CN -> "Common Name" (defaults "*")

You then will get a "more valid" certificate in the eyes of your browser.



[#] Fri Sep 18 2015 05:41:40 EDT from dothebart @ Uncensored

Subject: Re: Citadel Rasberry Pi to XML

[Reply] [ReplyQuoted] [Headers] [Print]

[#] Fri Sep 18 2015 12:43:50 EDT from rolfijn @ Uncensored

Subject: Re: firefox sec_error_reused_issuer_and_serial

[Reply] [ReplyQuoted] [Headers] [Print]

Wow, that's pretty amazing. A crash I had indeed corrupted my database, and I made no backups. Because I didn't know what else could be broken and because there wasn't much in it, I did rebuild Citadel. I took the keys from the "old" installation and now I only get a warning instead of no allowing access at all!

Many thanks!

Fri Sep 18 2015 05:40:22 EDT from dothebart @ Uncensored Subject: Re: firefox sec_error_reused_issuer_and_serial

the reason here is, that citadel builds a fake CA, which then starts to issue certificates with #0.

Once you do that on a second place, it will build a similar CA, which also starts with #0 -> clash.

 

you can override them by setting these environment variables before starting webcit the 'first' time:

OU -> organizational Unit (defaults "Citadel server")

O -> Organization (defaults "Organization name")

CN -> "Common Name" (defaults "*")

You then will get a "more valid" certificate in the eyes of your browser.



 



[#] Sun Sep 20 2015 11:57:19 EDT from James @ Uncensored

Subject: Restore specific folder from e-mail backup

[Reply] [ReplyQuoted] [Headers] [Print]

I have a citadel server. Thunderbird via IMAP went crazy and deleted an entire user's inbox. I have a backup from a while ago, so I don't want to overwrite the entire server, but would like to get back the inbox for this user so they get at least some of their mail back. I used the offline backup method where I shut down citadel, copy the databases over and when done restart citadel. How do I restore a single folder of e-mail from this database dump?



[#] Wed Sep 23 2015 17:19:15 EDT from polinux @ Uncensored

Subject: Docker Image with Citadel and WebCit

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Guys, 

 

I thought that you might get interested. :) I have prepared a easy to deploy Docker image with Citadel and WebCit which can be deployed by running one command. Hopefully that would make deployment easier for some less advanced users. Please feel free to let me know what you think and hopefully you will like it. :) 

Likns

Docker Hub 

GitHub 

 

 



[#] Wed Sep 23 2015 20:29:04 EDT from kelkel @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Hello everyones !

 

i am installing a fresh new citadel on my debian wheezy and everything went fine, except... i can't acces to webcit !

i have an existing apache2 install and chrome display me a  timeout message....

what can i do and where are the logs of citweb ?

thanks guys.



[#] Fri Sep 25 2015 08:55:59 EDT from KissMyAsthma13 @ Uncensored

Subject: Citadel berkeley db

[Reply] [ReplyQuoted] [Headers] [Print]

Hello

 

How do I access data on Berkeley db? 

 

I was able to export as xml but I actually want to see what's going on inside.

From what I know I need an API to access data but wasn't able to build/load one

 

I'm running Citadel webmail server on Raspberry Pi

Raspbian  OS



[#] Sun Sep 27 2015 06:37:31 EDT from dothebart @ Uncensored

Subject: Re: Citadel berkeley db

[Reply] [ReplyQuoted] [Headers] [Print]

http://code.citadel.org/?p=citadel.git;a=blob;f=citadel/techdoc/hack.txt;h=1af927555f80139ae118509743c5f3dd9773da18;hb=HEAD

contains the documentation how message structures are wrapped into the berkeley db.

This is the actual function doing that:

http://code.citadel.org/?p=citadel.git;a=blob;f=citadel/msgbase.c;h=d8b1ac9d2bd6b573806c92294731f0b81f4c1972;hb=HEAD#l1087

In general i'd say: "No user serviceable parts inside."



[#] Mon Sep 28 2015 03:56:11 EDT from KissMyAsthma13 @ Uncensored

Subject: Re: Citadel berkeley db

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Sep 27 2015 06:37:31 EDT from dothebart @ Uncensored Subject: Re: Citadel berkeley db

http://code.citadel.org/?p=citadel.git;a=blob;f=citadel/techdoc/hack.txt;h=1af927555f80139ae118509743c5f3dd9773da18;hb=HEAD

contains the documentation how message structures are wrapped into the berkeley db.

This is the actual function doing that:

http://code.citadel.org/?p=citadel.git;a=blob;f=citadel/msgbase.c;h=d8b1ac9d2bd6b573806c92294731f0b81f4c1972;hb=HEAD#l1087

In general i'd say: "No user serviceable parts inside."



Thank You !

I've been browsing the web for 4 weeks without any success of finding any houseful info 

I'll read through all this today and hopefully I'll finally understand what's the deal with Berkeley db 

 

Once again Thank You !



Go to page: First ... 62 63 64 65 [66] 67 68 69 70 ... Last