Language:
switch to room list switch to menu My folders
Go to page: First ... 55 56 57 58 [59] 60 61 62 63 ... Last
[#] Mon Aug 17 2015 16:35:59 EDT from cryptearth @ Uncensored

Subject: Re: can't start-up citadel after update opensuse 13.1 to 13.2 on ovh

[Reply] [ReplyQuoted] [Headers] [Print]

Well, that didn't helped (obviously, as what's written in this script is just : copy to tmp - delete current files - reload from tmp ~ I'm not see how this should help at all).

Another think that kinda bothered me : on OpenSuSE you need to add the doc-package as it contains the script and also add Berkeley-utils (wich should be marked as a dependency) wich contains the need binaries.

To be true : I guessed this wouldn't help at all because citadel fails on creating these files on the first time.

I also set-up a 13.1-vm and copied the 13.1 files to the 13.2 vm - still getting the same error.

So for me it seems there could be two reasons left : 1) error in release for 13.2 - 2) error on dependecies.

Any other advice ?

Sadly, OVH doesn't allow me to step-back to 13.1 as it isn't available for install anymore.

 

What I had not tried so far : downloading source and building on my own. Maybe this is the next step I try.



[#] Tue Aug 18 2015 03:47:46 EDT from dothebart @ Uncensored

Subject: Re: can't start-up citadel after update opensuse 13.1 to 13.2 on ovh

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Aug 17 2015 16:35:59 EDTfrom cryptearth @ Uncensored Subject: Re: can't start-up citadel after update opensuse 13.1 to 13.2 on ovh

Well, that didn't helped (obviously, as what's written in this script is just : copy to tmp - delete current files - reload from tmp ~ I'm not see how this should help at all).

Another think that kinda bothered me : on OpenSuSE you need to add the doc-package as it contains the script and also add Berkeley-utils (wich should be marked as a dependency) wich contains the need binaries.

To be true : I guessed this wouldn't help at all because citadel fails on creating these files on the first time.

 

No, its not as obvious, since its not copying the files, but dumping and re-importing it.

In debian its not a dependency but a recommendation. I think its similar in the rpms.

 

I also set-up a 13.1-vm and copied the 13.1 files to the 13.2 vm - still getting the same error.

So for me it seems there could be two reasons left : 1) error in release for 13.2 - 2) error on dependecies.

Any other advice ?

Sadly, OVH doesn't allow me to step-back to 13.1 as it isn't available for install anymore.

What I had not tried so far : downloading source and building on my own. Maybe this is the next step I try.



since the error comes from the berkeley db layer which citadel sits on top of, that may be the next step.



[#] Tue Aug 18 2015 12:23:49 EDT from jcigala @ Uncensored

Subject: Re: MIGR IMPORT not importing my messages

[Reply] [ReplyQuoted] [Headers] [Print]

Can I copy ctdlmigrate v8.24 and replace the version came with v9.01? I'm not a developer, I don't know if there are database issues or any other problem if I use the old ctdlmigrate version. What do you think?

 

 

Sun Aug 16 2015 06:45:16 EDT from dothebart @ Uncensored Subject: Re: MIGR IMPORT not importing my messages

Yes, I can confirm that the migrate in 9.01 is broken.

I've repaired several things, if you like to compile from git you should be able to utilize these fixes.

It also seems as if dumping & re-loading without the migr tool works better.

You can checkout the 9.01 tag and cherry-pick my commits over.



 



[#] Tue Aug 18 2015 19:02:50 EDT from cryptearth @ Uncensored

Subject: Re: can't start-up citadel after update opensuse 13.1 to 13.2 on ovh

[Reply] [ReplyQuoted] [Headers] [Print]

Well, I tried the easy-install-script in a fresh new clean VM, and the error still exists. It builds just fine, but if it tries to start up the same error message appears.

As noted earlier : I can't change libdb as many system-level things depends on it.

So, even as the own build failed I guess there is something wrong with the B-DB of OpenSuSE 13.2 wich causes this error.

Is there anyway around it so citadel doesn't use they main libdb but the donwloaded one ? As I really want to continue usin Citadel. Would appreciate any help.



[#] Tue Aug 18 2015 19:07:09 EDT from cryptearth @ Uncensored

Subject: Re: can't start-up citadel after update opensuse 13.1 to 13.2 on ovh

[Reply] [ReplyQuoted] [Headers] [Print]

*gnarf* - why there isn't an edit-function ? nevermind ...

to add : as there seems errors with berkeley-db is it possible to switch the db-layer to some like mysql ? I mean : if the db-layer is good seperated and the communication follows standard-sql it shouldn't matter what kind of database-system is on the other end of the connector. Or is citadel so tightly bound to berkeley db ?



[#] Wed Aug 19 2015 09:57:53 EDT from sp534d @ Uncensored

Subject: Unable to connect to web page (no loging)

[Reply] [ReplyQuoted] [Headers] [Print]

Shot myself in the foot.

   After trying to change the website port to 200 (which I could not make work) I change webcit back to port 80 and rebooted.

I can no longer access the web page (503 error) and cannot find any log files. Running process are listed

root      2339     1  0 08:45 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.80 -p80 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.80.log
nobody    2341  2339  0 08:45 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.80 -p80 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.80.log
root      2345     1  0 08:45 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
nobody    2348  2345  0 08:45 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s

webcit file

export WEBCIT_APACHEFLAG=' '
export WEBCIT_CITADEL_IP='127.0.0.1'
export WEBCIT_CITADEL_PORT='504'
export WEBCIT_HTTPS_PORT='443'
export WEBCIT_HTTP_PORT='80'
export WEBCIT_LANG='UNLIMITED'
export WEBCIT_LISTEN_IP='0.0.0.0'

So question ... what else changed when I change HTTP_PORT='80" to '2000' ?

How may I turn on logging so something will show up in logs (anywhere) ?

 

Thanks



[#] Wed Aug 19 2015 10:44:53 EDT from cryptearth @ Uncensored

Subject: Re: Unable to connect to web page (no loging)

[Reply] [ReplyQuoted] [Headers] [Print]


As Webcit is just a web-frontend it may help to uninstall und reinstall webcit by its own to restore to default configs.



[#] Thu Aug 20 2015 08:55:37 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: MIGR IMPORT not importing my messages

[Reply] [ReplyQuoted] [Headers] [Print]

Can I copy ctdlmigrate v8.24 and replace the version came with v9.01? I'm
not

Unfortunately no, ctdlmigrate is just a convenient wrapper around export/import functions built into Citadel Server. If your source and target systems are the same CPU architecture and bit width, you can instead just copy your binary data files over. You'll need to copy all of the following:

citadel.config, citadel.control (these are individual files, and important ones)
data/
bio/
images/
netconfigs/
userpics/

[#] Thu Aug 20 2015 15:55:46 EDT from MJCOC @ Uncensored

Subject: Citidel VMware/ESX 5 Package?

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a package like there was for ESXi 4 that would allow me to deploy Citadel with SPAMAssassin and ClamAV integrated and all ready to roll in to a VM? I am looking to replace my existing email server with something more robust in a VM environment and Citadel looks pretty strong. Thank you.

 

 



[#] Thu Aug 20 2015 17:23:01 EDT from "Jorgen Ottosson" <list.citadel@acme.nu> to citadel_support@citadel.org

Subject: New user, a few questions, some issues

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I have looked at Citadel earlier but never tried it. Now I installed it
and after having started to learn the various concepts and features I
think it looks really nice. And it has a number of useful features that I
would like to use.

I'm on Ubuntu 14.04 and latest version from repo.

I have a few problems with the setup though it seems.

I set up a number of rooms as RSS Feeds and some of them work and update
as expected but some dont at all. They are all set up in the same way. All
RSS URLs work in browsers.

Are there limits or issues I need to be aware of with feeds?

I also set up a few rooms with POP3 remote retrieval (internal mailserver)
and I got some emails over but then for some reason no more emails comes
over, despite more is coming into the pop user.

Also I did a session log inside the pop server and it shows Citadel pop
client is logged in, password ok, listing is received with a number of
emails waiting etc. A number of UIDL commands are sent but no RETR.
There's an OK from mailserver, there seems to be no errors in syntax etc.

I first used setting to save mail on server but changed and also removed
entry alltogether and added again, still couldn't get all emails down.

What am I missing here?

BTW I had to manually add the folder "/etc/citadel/netconfigs" before I
was able to save the remote retrieval settings at all.

Maybe I'm missing something else that for some reason is not configured
correctly with the repo version?


Any comments on any of the above appreciated.

TIA,
Jorgen

[#] Sun Aug 23 2015 22:13:32 EDT from crazymin @ Uncensored

Subject: Easiest way to install 9.x on Ubuntu or Debian?

[Reply] [ReplyQuoted] [Headers] [Print]

Sorry for the noob request here, but I have been trying to install Citadel on either Debian or Ubuntu and when I follow the apt-get directions from the site I get 8.24. I tried adding the new source to the source list, but this did not make a difference (unless of course I did it wrong). I also tried the build from source instructions and also got 8.24. Am I missing something painfully obvious here? If I have a fresh build of Debian or Ubuntu (whatever version you recommend), what is the easiest way to get 9.x on it?

Thanks!



[#] Sun Aug 23 2015 23:31:30 EDT from crazymin @ Uncensored

Subject: Re: Easiest way to install 9.x on Ubuntu or Debian?

[Reply] [ReplyQuoted] [Headers] [Print]

I guess 8.24 is the newest and 9.x is not official yet. When I was looking on the release site I saw 9.x as a latest stable and assumed that meant it was latest version for production, not dev. 

Anyone know estimated release date for 9.x?



[#] Mon Aug 24 2015 05:58:57 EDT from nnnn20430 @ Uncensored

Subject: spam

[Reply] [ReplyQuoted] [Headers] [Print]

how do i make a filter to move spam to another folder? i have spamassasin setup and i think it works from seeing "spamd[3109]: spamd: result: Y 15" in journal

i have configured citadel to flag messages instead of rejecting em because i'm paranoid it might reject a false positive

i tried making a filter to move to Spam folder by doing "if X-Spam-Flag contains YES move message to spam" but that didn't work what does X-Spam-Flag contain ??

also tried X-Spam-Status contains Yes

but messages still end up in inbox and not in Spam folder

what values do X-Spam-Flag or X-Spam-Status headers contain if it's flagged as spam ?



[#] Mon Aug 24 2015 07:24:30 EDT from nristen @ Uncensored

Subject: Re: Easiest way to install 9.x on Ubuntu or Debian?

[Reply] [ReplyQuoted] [Headers] [Print]

Use the "Easy Install" method mentioned at the top of the Download page on citadel.org

[#] Mon Aug 24 2015 23:52:14 EDT from eriix @ Uncensored

Subject: Re: spam

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Aug 24 2015 05:58:57 EDT from nnnn20430 @ Uncensored Subject: spam

how do i make a filter to move spam to another folder? i have spamassasin setup and i think it works from seeing "spamd[3109]: spamd: result: Y 15" in journal

i have configured citadel to flag messages instead of rejecting em because i'm paranoid it might reject a false positive

i tried making a filter to move to Spam folder by doing "if X-Spam-Flag contains YES move message to spam" but that didn't work what does X-Spam-Flag contain ??

also tried X-Spam-Status contains Yes

but messages still end up in inbox and not in Spam folder

what values do X-Spam-Flag or X-Spam-Status headers contain if it's flagged as spam ?



Just a thought, but how about hitting the "[Headers]" button on one of them to check?  I can't give you the results, since I don't use spam checking, but a header should be a header, right?



[#] Tue Aug 25 2015 01:27:16 EDT from "nnnn20430" <nnnn20430@mindcraft.si.eu.org> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Re: spam

[Reply] [ReplyQuoted] [Headers] [Print]


On 08/25/2015 05:52 AM, eriix wrote:

 

Mon Aug 24 2015 05:58:57 EDT from nnnn20430 @ Uncensored Subject: spam

how do i make a filter to move spam to another folder? i have spamassasin setup and i think it works from seeing "spamd[3109]: spamd: result: Y 15" in journal

i have configured citadel to flag messages instead of rejecting em because i'm paranoid it might reject a false positive

i tried making a filter to move to Spam folder by doing "if X-Spam-Flag contains YES move message to spam" but that didn't work what does X-Spam-Flag contain ??

also tried X-Spam-Status contains Yes

but messages still end up in inbox and not in Spam folder

what values do X-Spam-Flag or X-Spam-Status headers contain if it's flagged as spam ?



Just a thought, but how about hitting the "[Headers]" button on one of them to check?  I can't give you the results, since I don't use spam checking, but a header should be a header, right?

nope nothing just the usual headers, i guess they get removed after processing is over.


[#] Tue Aug 25 2015 01:36:51 EDT from "nnnn20430" <nnnn20430@mindcraft.si.eu.org> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Re: spam

[Reply] [ReplyQuoted] [Headers] [Print]


On 08/25/2015 05:52 AM, eriix wrote:

 

Mon Aug 24 2015 05:58:57 EDT from nnnn20430 @ Uncensored Subject: spam

how do i make a filter to move spam to another folder? i have spamassasin setup and i think it works from seeing "spamd[3109]: spamd: result: Y 15" in journal

i have configured citadel to flag messages instead of rejecting em because i'm paranoid it might reject a false positive

i tried making a filter to move to Spam folder by doing "if X-Spam-Flag contains YES move message to spam" but that didn't work what does X-Spam-Flag contain ??

also tried X-Spam-Status contains Yes

but messages still end up in inbox and not in Spam folder

what values do X-Spam-Flag or X-Spam-Status headers contain if it's flagged as spam ?



Just a thought, but how about hitting the "[Headers]" button on one of them to check?  I can't give you the results, since I don't use spam checking, but a header should be a header, right?

ah never mind the previous message, i used webcit ui to check headers, now i checked source using a mail client (Thunderbird) and there it is
X-Spam-Level: ***************
X-Spam-Status: True, score=15.1 required=5.0

ok so it's true not yes, every where i looked say it's either YES Yes or Y... oh well, hm i wish i could use X-Spam-Level header and just check if it has 5 stars,
but there doesn't seem to be a option to choose that header in filter settings just X-Spam-Flag and X-Spam-Status, and idk what X-Spam-Flag is.




[#] Tue Aug 25 2015 06:02:38 EDT from akong @ Uncensored

Subject: Have vacation(auto-respond) feature?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

Like a title.

Have auto-respond feature?

I can't found this feature in Citadel.



[#] Tue Aug 25 2015 11:25:40 EDT from cryptearth @ Uncensored

Subject: Re: can't start-up citadel after update opensuse 13.1 to 13.2 on ovh

[Reply] [ReplyQuoted] [Headers] [Print]

Yea, I know, pushing is not the best way to keep a topic up on the top, but sadly I still didn't got any response to my question.

But nevermind. As some friends of mine showed me some disadvangtages of citadel while I tried to fix this problem and also tried to setup other groupware systems I now decided to use a simple Apache James and some cheap forum-software to bring my site back up alive again.

Sorry to leave you guys, but there are better solutions than wait for a fix.



[#] Tue Aug 25 2015 19:43:37 EDT from marisag @ Uncensored

Subject: Setting up SSL on ubuntu 14.04

[Reply] [ReplyQuoted] [Headers] [Print]

I used the easy install and got citadel up and running, but it did not create any SSL files as it did on my other servers. I tried rerunning the easy install setup and the webcit setup utility but had the same results. How do I get webcit to use https on port 2001? And of course to use SSL for the citadel components also.

Help!

Marisa



Go to page: First ... 55 56 57 58 [59] 60 61 62 63 ... Last