Language:
switch to room list switch to menu My folders
Go to page: First ... 20 21 22 23 [24] 25 26 27 28 ... Last
[#] Fri Nov 07 2014 16:31:11 EST from DarkLogix @ Uncensored

Subject: Re: Address Book issue

[Reply] [ReplyQuoted] [Headers] [Print]


er I mean netstat is gone



[#] Fri Nov 07 2014 18:33:05 EST from "Buzz" <buzz@ksys.co.nz> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Error trying to confirm CitaNews' suscription.-

[Reply] [ReplyQuoted] [Headers] [Print]

On 08/11/14 01:40, jcigala wrote:
Hi All, I want to subscribe me to the CitaNews' mailing list I was
receiving the invitation email, this is:
I get the same message when trying to unsubscribe.

--
Cheers

Buzz

[#] Fri Nov 07 2014 21:57:01 EST from FigNewton @ Uncensored

Subject: Citadel on Ubuntu Virtual Machine.

[Reply] [ReplyQuoted] [Headers] [Print]

Guys, I jut wanted to say thanks for a smooth and simple swap. I was running an older email server and wanted to beef up the back end a little. I found Citadel, and decided I would give it a try. I went to my laptop and fired up a new machine with Qemu. I told it to use a VMware disk type as this was what was running on my target server. I got it up and running with ease. I have to commend everyone on the ease with which Citadel installed and was configured. Once I had all the settings worked out and was ready for a test run, I shut down the virtual machine, and copied the drive over to my server. I stopped the current email server and loaded up and turned on the new Citadel server. It fired up and ran like a charm. I now have ssl based pop3 and smtp so no passwords in plain text.

 

Kudos to the dev team!

Fig



[#] Sat Nov 08 2014 21:08:53 EST from FigNewton @ Uncensored

Subject: Yahoo and Maillists.

[Reply] [ReplyQuoted] [Headers] [Print]

I am trying to re-create a maillist that I had before and am running into and issue with Yahoo email addresses.

"Subject: Delivery Status Notification (Failure)

 

A message you sent could not be delivered to some or all of its recipients.

The following addresses were undeliverable:

(snipped)@yahoo.com: 5.7.9 Message not accepted for policy reasons. See http://postmaster.yahoo.com/errors/postmaster-28.html
The message was originaly posted in: Oldfolks"

 

If I go to the link yahoo provides, they have this statement:

"What you can do

In almost all cases, we recommend that you switch to sending mail from your own domain.  For mailing lists, also known as "listservs," you should change your sending behavior by adding the mailing lists’ address to the "From:" line, rather than the sender’s address.  Also, enter the actual user/sender address into the "Reply-To:" line."

In the room configuration, I have the "Which From Address should be used" set to oldfolks@[mydomain].com. I have "Alternative public emailaddresses pointing to this room:" with oldfolks@[mydomain].com added so that we don't have to use room_oldfolks@[mydomain].com. I have it going to a non-yahoo email, and it looks like the header shows that the From: line is coming from the originator's email address and not the maillist email. Is there a way to change this?

 

One last note, I have the recipients set up in the "The contents of this room are being mailed as individual messages to the following list recipients:" section. I don't see any explanation of the "Posts to this room will be sent to these mailing lists" block. I added the email addresses in there, but nothing comes through at all, so I moved them back to the individual message section. Any ideas?

 

 



[#] Sat Nov 08 2014 21:36:47 EST from FigNewton @ Uncensored

Subject: Yahoo and Maillist - more info.

[Reply] [ReplyQuoted] [Headers] [Print]

Here is another link provided by yahoo that explains their requirements.

http://yahoomail.tumblr.com/post/82426900353/yahoo-dmarc-policy-change-what-should-senders-do

 



[#] Sun Nov 09 2014 09:44:00 EST from MyrddinWyllt @ Uncensored

Subject: Re: bdb(): cursor still in progress on cdb 04

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I am also getting the same error (bdb(): cursor still in progress on cdb 04) after upgrading Centos to 6.6, and tried the same steps without success. As this is a test server, I also tried completely re-installing citadel, both as an Easy Install and from the repo at  http://download.opensuse.org/repositories/home:/homueller:/citadel/CentOS_CentOS-6/ ; in both cases, I got the same error as soon as citserver tried to start for the first time. Has anybody managed to get this working, or any ideas on how to fix it / where to start looking? Thanks in advance

Myrddin

 

Mon Nov 03 2014 05:56:30 EST from Radbruch1929 @ Uncensored Subject: bdb(): cursor still in progress on cdb 04

Hello,

 

I am somewhat stuck on problem I seem to have caused on a server. I upgraded Centos to release 6.6 (final). Now, citserver does not start with the following message:

 

Nov  3 11:45:58 citserver[2273]: *** Citadel server engine v8.24 (build 5644ab7) ***
Nov  3 11:45:58 citserver[2273]: Copyright (C) 1987-2014 by the Citadel development team.
Nov  3 11:45:58 citserver[2273]: This program is distributed under the terms of the GNU General Public License.
Nov  3 11:45:58 citserver[2273]: 
Nov  3 11:45:58 citserver[2273]: Called as: /usr/sbin/citserver
Nov  3 11:45:58 citserver[2273]: libcitadel(unnumbered)
Nov  3 11:45:58 citserver[2273]: Loading citadel.config
Nov  3 11:45:58 citserver[2273]: Acquiring control record
Nov  3 11:45:58 citserver[2273]: master_startup() started
Nov  3 11:45:58 citserver[2273]: Opening databases
Nov  3 11:45:58 citserver[2273]: bdb(): open_databases() starting
Nov  3 11:45:58 citserver[2273]: Compiled db: Berkeley DB 4.7.25: (November 12, 2010)
Nov  3 11:45:58 citserver[2273]:   Linked db: Berkeley DB 4.7.25: (September 12, 2013)
Nov  3 11:45:58 citserver[2273]: Calculated dbversion: 4007025
Nov  3 11:45:58 citserver[2273]:   Previous dbversion: 4007025
Nov  3 11:45:58 citserver[2273]: Linked zlib: 1.2.3
Nov  3 11:45:58 citserver[2273]: bdb(): Setting up DB environment
Nov  3 11:45:58 citserver[2273]: dbenv->open(dbenv, /var/lib/citadel/data/, 5461, 0)
Nov  3 11:45:58 citserver[2273]: DB: Finding last valid log LSN: file: 1 offset 9210
Nov  3 11:45:58 citserver[2273]: DB: Recovery starting from [1][28]
Nov  3 11:45:58 citserver[2273]: DB: Recovery complete at Mon Nov  3 11:45:58 2014
Nov  3 11:45:58 citserver[2273]: DB: Maximum transaction ID 80000006 Recovery checkpoint [1][9542]
Nov  3 11:45:58 citserver[2273]: Starting up DB
Nov  3 11:45:58 citserver[2273]: Checking floor reference counts
Nov  3 11:45:58 citserver[2273]: bdb(): cursor still in progress on cdb 04: can't begin transaction during r/o cursor
Nov  3 11:45:58 citserver[2273]: citserver is stopping in order to prevent data loss. uid=0 gid=0 euid=0 egid=0

I did the following:

a) ran db_recover -c in the directory

b) ran the dump/recover steps from database_cleanup.sh by hand

c) used a backup from yesterday.

 

I still can not recover from the cursor error. My DB_CONFIG file contains the following lines:

set_lk_max_locks 2000
set_lk_max_lockers 2000
set_lk_max_objects 2000

The citadel version comes from citadel.x86_64 0:8.24-7.1 RPM.

 

Anybody any ideas?

 

Thank you very much in advance,

 

Radbruch



 



[#] Mon Nov 10 2014 01:53:13 EST from bainwave @ Uncensored

Subject: Citadel Server Issues.

[Reply] [ReplyQuoted] [Headers] [Print]

Team,

I have been using this server nearly one year.

Am facing an issue, please help me out.

Citadel Service is stopping on every weekend (Saturday Night). I need to restart the machine, despite of restarting, stopping, starting the Citadel service from CLI.

Dont understand why the service is not running all the time.

Help me out please on resolving

--

Bain



[#] Mon Nov 10 2014 10:16:15 EST from dothebart @ Uncensored

Subject: Re: Citadel Server Issues.

[Reply] [ReplyQuoted] [Headers] [Print]

Please have a look at /var/log/syslog and /var/log messages, and search for the time range where citserver goes missing.

You should find something in there.



[#] Tue Nov 11 2014 06:18:45 EST from ura soul @ Uncensored

Subject: receiving messages via citadel from @mydomain.tld - + spam messages

[Reply] [ReplyQuoted] [Headers] [Print]

ever since i installed citadel i  have occasionally received empty emails from @mydomain.tld - with no username preceeding the @ symbol.

i didn't see any problem with this and thought it must be a harmless/buggy admin feature that i didn't know about.

today i received a spam email from that same address, that was sent to an old email address that i don't  use day to day, but that is within citadel.

i am unclear on whether this email was forwarded to me by citadel using this mysterious empty user account at my domain for some reason.. or whether my server is hacked and i have been the recipient of spam from my own server.

i think that the first case is most likely, but have no hint as to how to learn more about this presently.

i looked in the list of users within citadel and i only see the ones i have created, plus several ones that begin with SYS.

any tips?
thanks



[#] Tue Nov 11 2014 09:28:16 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Address Book issue

[Reply] [ReplyQuoted] [Headers] [Print]

er I mean netstat is gone

A quick Google search tells me that netstat is provided by the "net-tools" package on CentOS. Please "yum install net-tools" and then provide the output of "netstat -nlp | grep cit" for us to look at.

[#] Thu Nov 13 2014 04:05:06 EST from TheOneLaw @ Uncensored

Subject: Clamav-daemon failure logging virus scan

[Reply] [ReplyQuoted] [Headers] [Print]

Just grazing past looking for anyone else who may have noticed how Clamav-Daemon needs

 some special attention to get it to log whatever the frak it thinks it is doing.

(we think we are running citserver 8.24

I probably just mis-configured something somewhere because in the logs

 I do see the connection (on port3310) does occur and STREAMs do seem to initialize.

nothing serious at the moment but I am circling this to see what I can find out.

To be sure it appears to be some issue of clam and certainly not citadel

 

cheers

 

-- 
TheOneLaw



[#] Thu Nov 13 2014 09:29:59 EST from imgx64 @ Uncensored

Subject: STARTTLS on port 25

[Reply] [ReplyQuoted] [Headers] [Print]

Are there any plans for supporting STARTTLS for received emails on port 25?

https://starttls.info/check/citadel.org suggests that it's currently not supported by Citadel.



[#] Fri Nov 14 2014 03:47:07 EST from dothebart @ Uncensored

Subject: Re: STARTTLS on port 25

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Nov 13 2014 09:29:59 EST from imgx64 @ Uncensored Subject: STARTTLS on port 25

Are there any plans for supporting STARTTLS for received emails on port 25?

https://starttls.info/check/citadel.org suggests that it's currently not supported by Citadel.



hm, I guess its just a matter of anouncing the availability.

port 587 arounces starttls.



[#] Fri Nov 14 2014 09:13:46 EST from IGnatius T Foobar @ Uncensored

Subject: Re: STARTTLS on port 25

[Reply] [ReplyQuoted] [Headers] [Print]


We used to announce STARTTLS on port 25 as well, but there were some clients out there which attempted it and failed, and mail wasn't being delivered.

[#] Sat Nov 15 2014 18:49:36 EST from csg @ Uncensored

Subject: Re: SSL/TLS support for LDAP authentication

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Nov 04 2014 10:00:19 EST from IGnatius T Foobar @ Uncensored Subject: Re: SSL/TLS support for LDAP authentication

Lloyd -- I tried applying your patch but it didn't apply cleanly. I put your changes in manually but it failed to bind to the LDAP server and communicate clearly.

Can you please send a patch against the current svn head? Thanks.

I apologise for the delay in responding.  I have done a 'git clone' of the latest code-base and am investigating how to patch this code.

Interesting, the latest code uses ldap_initialize already. I will provide an update when done.

 

Best wishes,

 Lloyd Kamara


 



[#] Sun Nov 16 2014 01:35:42 EST from ax25 @ Uncensored

Subject: Re: Citadel on Ubuntu Virtual Machine.

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Nov 07 2014 09:57:01 PM EST from FigNewton @ Uncensored Subject: Citadel on Ubuntu Virtual Machine.

Guys, I jut wanted to say thanks for a smooth and simple swap. I was running an older email server and wanted to beef up the back end a little. I found Citadel, and decided I would give it a try. I went to my laptop and fired up a new machine with Qemu. I told it to use a VMware disk type as this was what was running on my target server. I got it up and running with ease. I have to commend everyone on the ease with which Citadel installed and was configured. Once I had all the settings worked out and was ready for a test run, I shut down the virtual machine, and copied the drive over to my server. I stopped the current email server and loaded up and turned on the new Citadel server. It fired up and ran like a charm. I now have ssl based pop3 and smtp so no passwords in plain text.

 

Kudos to the dev team!

Fig



Glad to have you on-board Fig!  You sound like someone who can help lighten the load and spread the word.  I would be interested in some of the more detailed bits of your migration as well if you are willing to share.



[#] Sun Nov 16 2014 07:47:12 EST from IGnatius T Foobar @ Uncensored

Subject: Re: SSL/TLS support for LDAP authentication

[Reply] [ReplyQuoted] [Headers] [Print]

I apologise for the delay in responding.  I have done a 'git clone' of
the
latest code-base and am investigating how to patch this code.

Interesting, the latest code uses ldap_initialize already. I will provide
an
update when done.

It was such a good idea that after your patch failed to apply, I started doing something similar. But your patch looked like it cleaned up the code in a number of other areas, so it would still be great to have.

One of the things I am envisioning for Citadel 9 is a new config system.
At that point we can replace the old "LDAP host" and "LDAP port" entries with an "LDAP URL" entry, without clobbering the old values on existing systems.

[#] Sun Nov 16 2014 11:46:07 EST from imgx64 @ Uncensored

Subject: Re: STARTTLS on port 25

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Nov 14 2014 09:13:46 EST from IGnatius T Foobar Subject: Re: STARTTLS on port 25

We used to announce STARTTLS on port 25 as well, but there were some clients out there which attempted it and failed, and mail wasn't being delivered.

I'm guessing they failed because the server was using a self-signed or an invalid certificate? Is it possible to detect a valid certificate and announce STARTTLS in that case only?



[#] Sun Nov 16 2014 12:11:40 EST from ulis.cat @ Uncensored

Subject: Citadel 8.24-7.1 DB errors

[Reply] [ReplyQuoted] [Headers] [Print]

Hello. Just installed citadel on OpenSuse 13.2

Installed from here: http://download.opensuse.org/repositories/home:/homueller:/citadel/openSUSE_13.1/i586/

Citserver does not start with the following errors:

citserver[11536]: *** Citadel server engine v8.24 (build 5644ab7) ***
citserver[11536]: Copyright (C) 1987-2014 by the Citadel development team.
citserver[11536]: This program is distributed under the terms of the GNU General Public License.
citserver[11536]:
citserver[11536]: Called as: /usr/sbin/citserver
citserver[11536]: libcitadel(unnumbered)
citserver[11536]: Loading citadel.config
citserver[11536]: Acquiring control record
citserver[11536]: master_startup() started
citserver[11536]: Opening databases
citserver[11536]: bdb(): open_databases() starting
citserver[11536]: Compiled db: Berkeley DB 4.8.30: (May 12, 2014)
citserver[11536]:   Linked db: Berkeley DB 4.8.30: (May 12, 2014)
citserver[11536]: Calculated dbversion: 4008030
citserver[11536]:   Previous dbversion: 0
citserver[11536]: Linked zlib: 1.2.8
citserver[11536]: bdb(): Setting up DB environment
citserver[11536]: dbenv->open(dbenv, /var/lib/citadel/data/, 10899, 0)
citserver[11536]: Starting up DB
citserver[11536]: Checking floor reference counts
citserver[11536]: bdb(): cursor still in progress on cdb 00: can't begin transaction during r/o cursor
citserver[11536]: citserver is stopping in order to prevent data loss. uid=0 gid=0 euid=0 egid=0

 

Tried to rebuild and reinstall from srpms from here:http://download.opensuse.org/repositories/home:/homueller:/citadel/openSUSE_13.1/src/

Cleaned directory /var/lib/citadel/data before starting.

Error is still there.

Please advise, how to overcome it?



[#] Sun Nov 16 2014 12:53:18 EST from ulis.cat @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Go to page: First ... 20 21 22 23 [24] 25 26 27 28 ... Last