Language:
switch to room list switch to menu My folders
Go to page: First ... 28 29 30 31 [32] 33 34 35 36 ... Last
[#] Fri Dec 04 2009 13:50:04 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #9 from Eric <elaganowski@hotmail.com> 2009-12-04 13:50:03 EST ---
Just tested the patch. It looks much more promising. I can verify that
multi-line logins now work in principal (from a telnet session), however there
is still a problem:
if you look at my Kolab capture, nginx appends something in curly braces to the
username, i.e. "some@email.net {8}", which, I think, is being forwarded for
authentication in its entirety, which causes invalid username/password
response.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Mon Dec 14 2009 23:12:34 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 530] New: sieve is failing on some headers

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=530

Summary: sieve is failing on some headers
Product: Citadel
Version: current version
Platform: PC
OS/Version: Linux
Status: NEW
Severity: blocker
Priority: P5
Component: Sieve
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: adam@colabx.com
Estimated Hours: 0.0


I'm not sure what's to blame, whether it's sieve or something in citadel. It
kind of looks like sieve, but...

I've got a citadel setup that receives mail in a roundabout way. It hits the
incoming mail server in one organization, bounces through 3 servers and then
hits my server. The first server runs spamassassin against all mail, so some
SA headers are there.

Quite often, sieve is failing to parse messages with the SA headers in them,
and just outright fails to proceed with parsing, making filtering unexpectedly
bad on this citadel.

An example of what sieve is doing:

Dec 14 19:27:28 [citadel] Sieve: Begin NAME_
Dec 14 19:27:28 [citadel] Sieve: NAME: X-Spam-Checker-Version_
Dec 14 19:27:28 [citadel] Sieve: header: NAME COLON body: Received:(qmail 20245
invoked by uid 0); 15 Dec 2009 03:27:23 -0000_
Dec 14 19:27:28 [citadel] Sieve: Entering name and body into header struct_
Dec 14 19:27:28 [citadel] Sieve: Prepending a new headerlist and header struct_
Dec 14 19:27:28 [citadel] Sieve: Begin TEXT, eat some whitespace and return
COLON_
Dec 14 19:27:28 [citadel] Sieve: TEXT: SpamAssassin 3.2.5 (2008-06-10) on
scan1b.xxxxxxx.com_
Dec 14 19:27:28 [citadel] Sieve: body: TEXT: SpamAssassin 3.2.5 (2008-06-10) on
scan1b.xxxxxxx.com_
Dec 14 19:27:28 [citadel] Sieve: Begin NAME_
Dec 14 19:27:28 [citadel] Sieve: NAME: X-Spam-Level_
Dec 14 19:27:28 [citadel] Sieve: header: NAME COLON body:
X-Spam-Checker-Version:SpamAssassin 3.2.5 (2008-06-10) on scan1b.xxxxxxx.com_
Dec 14 19:27:28 [citadel] Sieve: Entering name and body into header struct_
Dec 14 19:27:28 [citadel] Sieve: Prepending a new headerlist and header struct_
Dec 14 19:27:28 [citadel] Sieve: Begin NAME_
Dec 14 19:27:28 [citadel] Sieve: NAME: X-Spam-Status_
Dec 14 19:27:28 [citadel] Sieve: Header parse error: syntax error, unexpected
NAME, expecting COLON_
Dec 14 19:27:28 [citadel] sieve2_execute() returned 11: Sieve Error: header
could not be parsed_
Dec 14 19:27:28 [citadel] Completed sieve processing on msg <27898>_

Can anything be done to have sieve not fail out completely?


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 17 2009 16:08:34 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 531] New: User availability unknown/not functioning

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=531

Summary: User availability unknown/not functioning
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P5
Component: View: Calendar event Editor
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: adam@colabx.com
Estimated Hours: 0.0


Using citadel 7.70 and webcit 7.70 release (and I noticed this behaviour under
7.66 as well), free/busy and availability in webcit aren't being reported.

For example, userA has an appointment marking them busy on Dec. 18 between 1pm
and 3pm local time. UserB goes to create a calendar event in webcit, sets the
schedule for any particular time, adds userA to the attendees list, and hits
"check attendee availability". The page is refreshed back to the event tab,
and when looking then at the Attendees tab, the listing for userA shows:

userA (availability unknown) (status unknown)

Even if userB adds his self in as an Attendee, the same messages appear after
their entry in the Attendees list.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 17 2009 23:55:55 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #10 from Eric <elaganowski@hotmail.com> 2009-12-17 23:55:53 EST ---
I attempted to hack some code and it was partially successful. I am not a coder
at all and have no idea how to really code in C, that is why I will not post a
patch here, but the idea was to strtok_r(cmd," ",nil) before passing to
CtdlLoginExistingUser in imap_auth_login_user in serv_imap.c
The login is successful now, but one issue still remains:
Citadel returns " OK authentication succeeded" (see the leading space). It
looks like IMAP->authseq is not being printed as it should:
cprintf("%s OK authentication succeeded\r\n", IMAP->authseq);

At this point I am not sure what is wrong.

Wilfried, any ideas?


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Fri Dec 18 2009 12:55:44 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #11 from Eric Laganowski <elaganowski@hotmail.com> 2009-12-18 12:55:42 EST ---
Was able to fix the sequence number issue as well.
serv_imap.c:
void imap_login(int num_parms, char *parms[])
{

switch (num_parms) {
case 3:
if (parms[2][0] == '{') {
cprintf("+ go ahead\r\n");
IMAP->authstate = imap_as_expecting_multilineusername;
+ strcpy(IMAP->authseq, parms[0]);
return;

Please review my code here, I have no idea how to work with strings in C:
void imap_auth_login_user(char *cmd, long state)
{
char buf[SIZ];
+ char *myptr, *mylast;

..
case imap_as_expecting_multilineusername:
+ myptr = strtok_r(cmd, " ", &mylast);
- CtdlLoginExistingUser(NULL, cmd);
+ CtdlLoginExistingUser(NULL, myptr);
cprintf("+ go ahead\r\n");

After applying Wilfried's patch and applying my changes above I can confirm
that NGINX->Citadel IMAP connection at least goes through the login sequence
and I can see IMAP folders and messages.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Fri Dec 18 2009 14:48:28 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #12 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-18 14:48:27 EST ---
Created an attachment (id=69)
--> (http://bugzilla.citadel.org/attachment.cgi?id=69)
new version of patch

Ok, your c-way was correct (except that it probably could have been a leak but
don't know) This is the citadel way.
Though I don't know whether the citadel tokenizer should be 1 or like in your
case 0; Please try this patch.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Fri Dec 18 2009 14:49:28 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528


Wilfried Goesgens <dothebart@uncensored.citadel.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |ajc@uncensored.citadel.org




--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Fri Dec 18 2009 14:51:06 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #13 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-18 14:51:05 EST ---
IG, since you're the master of imap, please have a look at the current state of
this patch, and tell us whether we could apply this patch.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Sat Dec 19 2009 17:46:21 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 438] Usage bug - reading messages and changing order

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=438


Adam Clark <adam@colabx.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
Severity|minor |major




--- Comment #6 from Adam Clark <adam@colabx.com> 2009-12-19 17:46:19 EST ---
Would really like to see Newest to Oldest working before another stable release
is considered. I truly believe this is base functionality that has to 'just
work'.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Sat Dec 19 2009 18:15:53 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 438] Usage bug - reading messages and changing order

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=438





--- Comment #7 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-19 18:15:52 EST ---
there have been enough bugfixes (important ones) plus new feature to justify
the 7.70 release. IG is currently reworking the bbsview to be thread enabled,
which in term will fix this bug.
As usual, its going to be released when its ready. If there are more reasons
justifying a new release before its done, there will be more.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Sat Dec 19 2009 22:57:22 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 438] Usage bug - reading messages and changing order

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=438





--- Comment #8 from Adam Clark <adam@colabx.com> 2009-12-19 22:57:21 EST ---
Great, do look forward to the bbsview re-working.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 24 2009 15:19:40 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 532] New: XMPP clients not establishing connection

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=532

Summary: XMPP clients not establishing connection
Product: Citadel
Version: current version
Platform: PC
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P5
Component: Citadel server
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: adam@colabx.com
Estimated Hours: 0.0


Created an attachment (id=70)
--> (http://bugzilla.citadel.org/attachment.cgi?id=70)
tcpdump Attempted login session from PSI

Running citadel 7.70, I can't get kopete or PSI (psi-im.org) to establish
connection to citadel. They both hang trying to become "Available".

Pidgin, on the other hand, is able to get established, but then we see Bug 524
and the roster is either showing everyone offline or one only sees themselves
online in the roster.

I'm attaching the traffic dump from tcpdump from the PSI login attempt.

On the citadel side, it thinks the user is logged in:

Dec 24 12:11:16 [citadel] Session started from
S0106001bc03c8000.ok.shawcable.net [24.67.172.110]._
Dec 24 12:11:16 [citadel] <testuser> logged in_
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Mail, type=4, view=1)_
Dec 24 12:11:16 [citadel] Mail already exists._
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Sent Items, type=4, view=1)_
Dec 24 12:11:16 [citadel] Sent Items already exists._
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Trash, type=4, view=1)_
Dec 24 12:11:16 [citadel] Trash already exists._
Dec 24 12:11:16 [citadel] CtdlFetchMessage(14685, 1)_
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Contacts, type=4, view=2)_
Dec 24 12:11:16 [citadel] Contacts already exists._
Dec 24 12:11:16 [citadel] xmpp_queue_event(0, testuser@colabx.com)_
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Calendar, type=4, view=3)_
Dec 24 12:11:16 [citadel] Calendar already exists._
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Tasks, type=4, view=4)_
Dec 24 12:11:16 [citadel] Tasks already exists._
Dec 24 12:11:16 [citadel] CtdlCreateRoom(name=Notes, type=4, view=5)_
Dec 24 12:11:16 [citadel] Notes already exists._
Dec 24 12:11:16 [citadel] <Welcome> 0 new of 2 total messages_
Dec 24 12:11:20 [citadel] Client disconnected: ending session.__
Dec 24 12:11:20 [citadel] Purging session 2649_
Dec 24 12:11:20 [citadel] RemoveContext() session 2649_
Dec 24 12:11:20 [citadel] xmpp_queue_event(1, testuser@colabx.com)_
Dec 24 12:11:20 [citadel] [2649] Session ended._
Dec 24 12:11:20 [citadel] Closing socket 32_
Dec 24 12:11:20 [citadel] Done with RemoveContext()_
Dec 24 12:11:29 [citadel] NOOP_
Dec 24 12:11:30 [citadel] -- db checkpoint --_
Dec 24 12:11:35 [citadel] 1 sessions for <adam@colabx.com> are now visible to
session 2629_
Dec 24 12:11:35 [citadel] Telling session 2629 that <adam@colabx.com> logged
in_
Dec 24 12:11:35 [citadel] 1 sessions for <adam@colabx.com> are now visible to
session 2629_
Dec 24 12:11:35 [citadel] 0 sessions for <testuser@colabx.com> are now visible
to session 2629_
Dec 24 12:11:35 [citadel] Telling session 2629 that <testuser@colabx.com>
logged out_
Dec 24 12:11:35 [citadel] 0 sessions for <testuser@colabx.com> are now visible
to session 2629_
Dec 24 12:11:35 [citadel] Telling session 2629 that <testuser@colabx.com>
logged out_

I've tried logging in to my account at uncensored with PSI and Pidgin and find
exactly the same results with each client.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Tue Dec 29 2009 14:00:30 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 533] New: webcit not really themeable with colors hard coded in c source files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=533

Summary: webcit not really themeable with colors hard coded in c
source files
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: enhancement
Priority: P5
Component: General
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: adam@colabx.com
Estimated Hours: 0.0


Wishlist: Please remove all hard-coded colours and get them in as elements to
webcit.css. Grep the main webcit source directory for FFF and you'll see
several examples, though I'm sure that list will be quite incomplete.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Wed Dec 30 2009 18:42:28 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 533] webcit not really themeable with colors hard coded in c source files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=533


Wilfried Goesgens <dothebart@uncensored.citadel.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |dothebart@uncensored.citadel
| |.org
Status|NEW |RESOLVED
Resolution| |FIXED




--- Comment #1 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-30 18:42:26 EST ---
the proposed solution for this is to remove html from c alltogether. Its about
50% done; vcards, calendar, tasks and the summary are outstanding.
Have a look at the static/t/ directory, it already contains lots of templates
for easy modification.
As Wim's netbook theme shows, you are already able to change pretty much with
css.

Btw, we're still looking for a volunteer to build a set of descent templates
for user administration.

In general, that kind of sugestion should be done via the citadel development
room, and having a (at least partly) patch showing what is to be done in your
opinion.

Closing to keep bugzilla clean.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 31 2009 02:03:08 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 533] webcit not really themeable with colors hard coded in c source files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=533


Adam Clark <adam@colabx.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|RESOLVED |REOPENED
Resolution|FIXED |




--- Comment #2 from Adam Clark <adam@colabx.com> 2009-12-31 02:03:06 EST ---
Huh?

Perhaps you're looking to not have bug submitters.

I think this is a perfectly legitimate bug in that one can not create a dark
theme for webcit currently until the HTML is out of the C code altogether, like
this bug suggests.

I have already modified plenty out of the static and static/t directories and
this bug being filed is the result of discovering it is NOT POSSIBLE to fully
theme webcit without modifying the C source.

Why would you close this? It is definitely not fixed. Perhaps keep the bug
open and reference it until it's no longer a work-in-progress?


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 31 2009 07:03:17 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 533] webcit not really themeable with colors hard coded in c source files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=533





--- Comment #3 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-31 07:03:16 EST ---
as already sad, please head over to
citadel development
on uncensored, if you want to suppose a patch to SVN Head. Please note that
some templates were renamed/restructured recently.
See the citadel development list for a list.

Please coordinate your work with the_mgt who is idling in #citadel in freenode
IRC and is currently working on a way to have the possibility to move the
iconbar around in the layout. He also started templating the room
administration interface.

If you want to make this 'work in progress' by proposing patches, which is
probably the safest way to make this happen any time soon, (as noted above)
bugzilla is not the right place for discussions, again, IRC and/or Uncensored
are the places for that.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 31 2009 12:44:02 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 533] webcit not really themeable with colors hard coded in c source files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=533





--- Comment #4 from Adam Clark <adam@colabx.com> 2009-12-31 12:44:01 EST ---
This wasn't intended to be a discussion. It was posted as a bug because:

-> Webcit pretends to be themable to the administrator by having the static and
static.local directories containing graphics, templates and CSS.

However,

-> Not all elements are manageable by an administrator as they're hard-coded in
to the software's source.

Hence, an enhancement request to continue the work to get all elements in to
the static directory. I don't know enough about how the template calls are
made from webcit to do the work... yet. Otherwise I'd be happy to submit
patches.

I also figured a bug was necessary as without it, it's apparent the
templating/theming abilities aren't really being thought about much when coding
in (some of the) new features, as there's hard-coded color elements in things
like the new wiki code.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Fri Jan 08 2010 16:38:12 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 534] New: webcit ignoring primary internet e-mail address

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=534

Summary: webcit ignoring primary internet e-mail address
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P5
Component: View: Mail Editor
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: adam@colabx.com
Estimated Hours: 0.0


Running libcit/citadel/webcit 7.71, my users contact information has a primary
internet email address listed and several other internet email aliases.

When I go to write a mail, webcit is consistently choosing the 2nd internet
email alias in the list rather than the primary. The drop-down box allows me
to choose the appropriate From address (the Primary is the last entry in the
drop-down), but the default is wrong every time.

I verified this by adding in the primary internet email address as the 2nd
entry from the top in the email aliases list, and that now shows up as the
default selection when composing a message in the Mail room. The entry is
repeated down at the bottom of the drop-down as well.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Sat Jan 09 2010 09:22:37 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 534] webcit ignoring primary internet e-mail address

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=534





--- Comment #1 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2010-01-09 09:22:35 EST ---
you may configure your default from address in your personal preferences for
external emails and room posts.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Mon Jan 11 2010 17:08:12 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 534] webcit ignoring primary internet e-mail address

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=534





--- Comment #2 from Adam Clark <adam@colabx.com> 2010-01-11 17:08:10 EST ---
Right. That is exactly what is being ignored by webcit.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Go to page: First ... 28 29 30 31 [32] 33 34 35 36 ... Last