Language:
switch to room list switch to menu My folders
Go to page: First ... 27 28 29 30 [31] 32 33 34 35 ... Last
[#] Sun Nov 15 2009 16:56:51 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 469] Tasks do not sync from Thunderbird via SyncKolab

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=469





--- Comment #3 from Adam Clark <adam@colabx.com> 2009-11-15 16:56:50 EST ---
Actually it looks like this patch, or the functionality it was supposed to add
is actually in webcit 7.66. In webcit 7.66, entries from thunderbird &
synckolab don't show up in webcit at all. There are imap entries as noted
previously, but I guess because webcit thinks there's 0 task entries it's not
syncing from one thunderbird/synckolab to another, or to any other device.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Nov 19 2009 07:05:45 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 524] New: XMPP IM users appearing offline

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=524

Summary: XMPP IM users appearing offline
Product: Citadel
Version: current version
Platform: PC
OS/Version: Linux
Status: NEW
Severity: major
Priority: P5
Component: Citadel server
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: rait@kuma.ee
Estimated Hours: 0.0


Created an attachment (id=64)
--> (http://bugzilla.citadel.org/attachment.cgi?id=64)
tcpdump of port 5222 on Citadel server

The XMPP IM users in latest Pidgin appear as offline. Users can still send
messages to each other, even when appearing offline.

Kopete keeps giving the following notices:

The Jabber user username@mycitadel.ee removed myusername@mycitadel.ee's
subscription to him/her. This account will no longer be able to view his/her
online/offline status. Do you want to delete the contact?


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Nov 19 2009 14:31:18 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 525] New: webcit dumping core when trying to view file room's files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=525

Summary: webcit dumping core when trying to view file room's
files
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: blocker
Priority: P5
Component: General
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: adam@colabx.com
Estimated Hours: 0.0


Created an attachment (id=65)
--> (http://bugzilla.citadel.org/attachment.cgi?id=65)
Stable webcit's backtrace

I've tried setting up a file room on both my stable and svn citadel
deployments. The file room creation seems to go just fine, but in webcit when
I go to view the directory by clicking on "0 files" (the URI being
/do_template?template=files), nothing is returned to the browser, and webcit
core dumps.

I've attached the core dumps from both systems, gathered via gdb using "thread
apply all bt full" as per the documentation.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Nov 19 2009 14:31:54 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 525] webcit dumping core when trying to view file room's files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=525





--- Comment #1 from Adam Clark <adam@colabx.com> 2009-11-19 14:31:53 EST ---
Created an attachment (id=66)
--> (http://bugzilla.citadel.org/attachment.cgi?id=66)
SVN webcit's backtrace


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Nov 19 2009 14:55:00 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 525] webcit dumping core when trying to view file room's files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=525


Wilfried Goesgens <dothebart@uncensored.citadel.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |dothebart@uncensored.citadel
| |.org
Status|NEW |RESOLVED
Resolution| |FIXED




--- Comment #2 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-11-19 14:54:59 EST ---
hopefully fixed with r8065. please update and retry.

In general, please try to report with non optimized binaries (-O0 instead of
-O2)


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Nov 19 2009 15:32:16 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 525] webcit dumping core when trying to view file room's files

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=525





--- Comment #3 from Adam Clark <adam@colabx.com> 2009-11-19 15:32:15 EST ---
Fantastic, worked like a charm on both svn and stable. The patch didn't apply
cleanly to 7.66 stable (but possibly just the way I generated the diff from
subversion), but a hand-edit fixed it up and is working well.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Nov 19 2009 17:19:49 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 469] Tasks do not sync from Thunderbird via SyncKolab

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=469





--- Comment #4 from Adam Clark <adam@colabx.com> 2009-11-19 17:19:48 EST ---
Upstream has fixed some bugs in the task formatting, but upon testing, Citadel
doesn't like this task entry any better:

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
BEGIN:VTODO
CREATED:20091119T221456Z
LAST-MODIFIED:20091119T221520Z
DTSTAMP:20091119T221520Z
UID:e03aad3c-c8d8-448d-91c6-b0c309fb3a82
SUMMARY:Test new task\, hopefully good
STATUS:
ORGANIZER;RSVP=FALSE;CN=Adam Clark;PARTSTAT=ACCEPTED;ROLE=CHAIR:mailto:
adam@colabx.com
END:VTODO
END:VCALENDAR


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Fri Nov 20 2009 19:00:25 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 469] Tasks do not sync from Thunderbird via SyncKolab

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=469





--- Comment #5 from Adam Clark <adam@colabx.com> 2009-11-20 19:00:24 EST ---
I was able to make the synckolab plugin work by making a couple of changes in
it, both relating to the Content-Type.

Items that don't work from synckolab have a Content-Type: header that looks
like this:

Content-Type: text/todo;
charset="utf-8"

I changed it so it would just generate:

Content-Type: text/calendar;

And it works.

Could someone let me know if this is a bug that I should file upstream, or
whether it's something citadel should happily parse?

Thanks, hope this helps.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Sat Nov 28 2009 14:04:58 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 526] New: remove attachment

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=526

Summary: remove attachment
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: whishlist
Priority: P3
Component: View: Mail Editor
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: stefan@localside.net
Estimated Hours: 0.0


When creating an email in webcit, it is possible to add an attachment. But you
can not remove an already added attachment. (e.g. you picked the wrong file).
Would be nice to have a remove attachment button there.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Sat Nov 28 2009 14:14:25 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 527] New: attachments are not shown if email is signend (gpg, smime)

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=527

Summary: attachments are not shown if email is signend (gpg,
smime)
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P5
Component: View: Mailbox View
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: stefan@localside.net
Estimated Hours: 0.0


In webcit the attachment of a smime or gpg signed email is not shown. Webcit
shows only the signed file: smime.p7s (application/pkcs7-signature, 1961 bytes)
or: signature.asc (application/pgp-signature, 205 bytes)

I can send you a sample e-mail.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Mon Nov 30 2009 16:25:24 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] New: IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528

Summary: IMAP handling
Product: Citadel
Version: current version
Platform: PC
OS/Version: Linux
Status: NEW
Severity: blocker
Priority: P5
Component: Citadel Protocol
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: elaganowski@hotmail.com
Estimated Hours: 0.0


I am currently testing Citadel server with some unconventional design and I've
hit a roadblock with IMAP protocol.
Here is the setup:

win32 Thunderbird -- IMAP over SSL --> Nginx 0.8.27 -- plaintext IMAP -->
Citadel server 7.66

I have two IMAP servers as possible backends: Citadel and Kolab (Cyrus SASL)
The issue is that Kolab works, while Citadel does not.

The issue seems to be with the way Nginx talks to the backend server. I did
some packet captures and it shows the picture of what is going on. Here is the
IMAP decode:

Citadel:
* OK [CAPABILITY IMAP4REV1 NAMESPACE ID AUTH=PLAIN AUTH=LOGIN UIDPLUS STARTTLS
ACL METADATA] host IMAP4rev1 Citadel 7.66 ready
2 LOGIN {19}
2 BAD incorrect number of parameters

Kolab:
* OK host Cyrus IMAP4 v2.2.12 server ready
2 LOGIN {19}
+ go ahead
some@email.net {8}
+ go ahead
blah
2 OK User logged in

I am not sure what is this "go ahead" thing and part of which standard it is,
as good IMAP protocol description is hard to come by, but quick searches in
RFCs did not reveal anything relevant.

Is there a way to find out what needs to be fixed here?

-Eric


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Mon Nov 30 2009 17:19:08 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528


Wilfried Goesgens <dothebart@uncensored.citadel.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |dothebart@uncensored.citadel
| |.org




--- Comment #1 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-11-30 17:19:06 EST ---
could you run citserver from the commandline and post the output from
citserver? it probably contains some more helpfull output

the conversation you've posted is nginx imap proxy <-> citserver, right?

could you run a plain text connection, and post tbird <-> nginx too?

Most probably a direct tcpdump sniff might bring more information
see
http://www.citadel.org/doku.php/faq:mastering_your_os:net_sniff

for details.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Mon Nov 30 2009 17:49:34 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528


Eric <elaganowski@hotmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |elaganowski@hotmail.com




--- Comment #2 from Eric <elaganowski@hotmail.com> 2009-11-30 17:49:33 EST ---
Wilfried,

Thanks a lot for a quick reply. Yes, I posted nginx->citserver dump before.

Here is the info you have asked for:

tbird -> nginx
* OK IMAP4 ready
1 capability
* CAPABILITY IMAP4 IMAP4rev1 UIDPLUS AUTH=PLAIN
1 OK completed
2 authenticate plain
+
AGDyaWFAbGGnYF5vdTraS5uZXQAbW9udHkxMWs= <-- obfuscated
2 BAD incorrect number of parameters
3 login "some@email.net" "blah"


nginx -> citadel
* OK [CAPABILITY IMAP4REV1 NAMESPACE ID AUTH=PLAIN AUTH=LOGIN UIDPLUS STARTTLS
ACL METADATA] thule IMAP4rev1 Citadel 7.66 ready
2 LOGIN {19}
2 BAD incorrect number of parameters

This is the output of the same session captured by two tcpdump sessions running
simultaneously. I am pasting this as Wireshark IMAP protocol decode "Follow TCP
stream". If you think there is something missing from the conversation, I can
probably attach raw capture files, but I will need to do some cleanups.

This is the output of citadel server:

2009/11/30 22:42:05.134963 New client socket 32
2009/11/30 22:42:05.135090 [ 2] Session started from localhost [127.0.0.1].
2009/11/30 22:42:05.135370 [ 2] IMAP: LOGIN...
2009/11/30 22:42:05.135404 [ 2] IMAP: 2
2009/11/30 22:42:05.135414 [ 2] IMAP command completed in 0.76 seconds
2009/11/30 22:42:05.336290 [ 2] Client disconnected: ending session.
2009/11/30 22:42:05.336330 Purging session 2
2009/11/30 22:42:05.336339 RemoveContext() session 2
2009/11/30 22:42:05.336348 [ 2] xmpp_queue_event(1, )
2009/11/30 22:42:05.336375 [ 2] Performing IMAP cleanup hook
2009/11/30 22:42:05.336388 [ 2] Finished IMAP cleanup hook
2009/11/30 22:42:05.336396 [ 2] Session ended.
2009/11/30 22:42:05.336404 Closing socket 32
2009/11/30 22:42:05.336466 Done with RemoveContext()

Hope this helps.
- Eric


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Wed Dec 02 2009 12:54:15 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #3 from Eric <elaganowski@hotmail.com> 2009-12-02 12:54:14 EST ---
From my perspective this is clearly a problem with Citdel IMAP implementation
which apparently is unable to handle multi-line LOGIN sequence. I tried
single-line LOGIN and it worked. I am not sure if any further IMAP
communication with NGINX in particular would be affected, as I have not tested
enough (no need to as LOGIN is a blocker). The only thing I would like to know
whether this is a bug or something to be expected as, say NGINX is following
different IMAP RFC/extensions than Citadel?


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Wed Dec 02 2009 13:52:34 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 529] New: reply to message with attachment

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=529

Summary: reply to message with attachment
Product: WebCit
Version: 7.xx
Platform: PC
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P5
Component: View: Mail Editor
AssignedTo: room_citadel_bug_tracking@uncensored.citadel.org
ReportedBy: stefan@localside.net
Estimated Hours: 0.0


If you reply to a message in webcit which has an attachment then webcit will
not remove the attachment from the reply, instead it will be a part of the
reply. But in general you don't have an interest in resending the attachment.
In a reply all attachments should be removed or at least the user should have
the option to remove the attachment.

Citadel 7.66 with WebCit 7.66, in 7826M


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Wed Dec 02 2009 18:52:07 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #4 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-02 18:52:05 EST ---
Created an attachment (id=67)
--> (http://bugzilla.citadel.org/attachment.cgi?id=67)
first try to fix this

please try out this patch, and tell me whether its working then.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Wed Dec 02 2009 19:13:53 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #5 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-02 19:13:51 EST ---
Created an attachment (id=68)
--> (http://bugzilla.citadel.org/attachment.cgi?id=68)
last patch was broken

please revert if you applied the last, and add this one.


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Wed Dec 02 2009 22:11:38 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #6 from Eric <elaganowski@hotmail.com> 2009-12-02 22:11:37 EST ---
Probably will be able to do this some time tomorrow time permitting. I'll let
you know.

Thanks


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 03 2009 17:28:34 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #7 from Eric <elaganowski@hotmail.com> 2009-12-03 17:28:32 EST ---
Wilfried,

Which citadel build have you written this for? I have issues applying this
patch:

citadel-7.66 $ patch -Np0 -i ../citadel.patch
patching file modules/imap/serv_imap.c
Hunk #1 succeeded at 535 (offset -6 lines).
Hunk #2 FAILED at 641.
Hunk #3 succeeded at 1415 (offset 4 lines).
Hunk #4 FAILED at 1435.
2 out of 4 hunks FAILED -- saving rejects to file modules/imap/serv_imap.c.rej
patching file modules/imap/serv_imap.h

-Eric


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

[#] Thu Dec 03 2009 17:53:09 EST from "bugzilla-daemon" <bugzilla-daemon@web4.xand.com> to room_citadel_bug_tracking@uncensored.citadel.org

Subject: [Bug 528] IMAP handling

[Reply] [ReplyQuoted] [Headers] [Print]

http://bugzilla.citadel.org/show_bug.cgi?id=528





--- Comment #8 from Wilfried Goesgens <dothebart@uncensored.citadel.org> 2009-12-03 17:53:08 EST ---
it was done against SVN Head
have a look at
http://www.citadel.org/doku.php/installation:sourcecode
for more details.

if you want to build .debs from svn, have a look at

http://www.citadel.org/doku.php/installation:debian

or if easy install:
http://www.citadel.org/doku.php/installation:easyinstall:easyinstall:homebrew


--
Configure bugmail: http://bugzilla.citadel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Go to page: First ... 27 28 29 30 [31] 32 33 34 35 ... Last